aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-22 06:00:03 -0400
committerAisha Tammy <gentoo@aisha.cc>2020-09-22 06:00:03 -0400
commitd239355ea8af0370a9b94a90fac88eb7a38794e3 (patch)
tree2e39dc69af1a0bb7f574bb3bb4ee93616e6c1dc8 /sci-astronomy
parentsci-astronomy/bpz: drop package (diff)
downloadsci-d239355ea8af0370a9b94a90fac88eb7a38794e3.tar.gz
sci-d239355ea8af0370a9b94a90fac88eb7a38794e3.tar.bz2
sci-d239355ea8af0370a9b94a90fac88eb7a38794e3.zip
sci-astronomy/erfa: version bump
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/erfa/Manifest1
-rw-r--r--sci-astronomy/erfa/erfa-1.7.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/sci-astronomy/erfa/Manifest b/sci-astronomy/erfa/Manifest
index 0bc2bbff5..4fa7aee46 100644
--- a/sci-astronomy/erfa/Manifest
+++ b/sci-astronomy/erfa/Manifest
@@ -1 +1,2 @@
DIST erfa-1.7.0.tar.gz 656949 BLAKE2B 071ae7c5e60a8904b0b93a615c1a23d8db6ea7100e822cfa842f279ce6eed341426d6ef46131dfa92c3ec605c03eeb1c7f204238ad229d4ed524fbc91e58d39c SHA512 0a25faa22cc756776df40cfd927388077f7d253ee89fd4e21c4ddb35198dafd5fd7e9904d00f419675c5f3b26232b5bd04087d4a2f175da1f89179173f98692f
+DIST erfa-1.7.1.tar.gz 720703 BLAKE2B a8299ba397555aa8ac8ad1778171712ec8f5a5a89fcc26a3baa9df24a8c0d4abbf92908c2306777ff57c08cb76fb961f1729125a8777258f909d3c345fa3b983 SHA512 9596696bd34a017537180d29ed15a3562806b7d50a36f06ddc4c49ad9b6b39fbb25d72a03bd97447a78f8031a12a684def703a3463f4379b3863bd4dd0a46d1e
diff --git a/sci-astronomy/erfa/erfa-1.7.1.ebuild b/sci-astronomy/erfa/erfa-1.7.1.ebuild
new file mode 100644
index 000000000..ba7c72781
--- /dev/null
+++ b/sci-astronomy/erfa/erfa-1.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools eutils
+
+DESCRIPTION="Essential Routines for Fundamental Astronomy"
+HOMEPAGE="https://github.com/liberfa/erfa"
+SRC_URI="https://github.com/liberfa/erfa/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}