aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2023-09-01 10:01:15 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2023-10-28 12:00:36 +0200
commit2ab41c43e46466f6c6ee93829863a186ea89a570 (patch)
treeea89a4f885c2c942b7f857d32eaf90d5f5b08c44 /sci-physics/pyhf/pyhf-0.7.3.ebuild
parentdev-python/llvmlite: add 0.41.0 (diff)
downloadsci-2ab41c43e46466f6c6ee93829863a186ea89a570.tar.gz
sci-2ab41c43e46466f6c6ee93829863a186ea89a570.tar.bz2
sci-2ab41c43e46466f6c6ee93829863a186ea89a570.zip
sci-physics/pyhf: new package, add 0.7.3
Closes: https://github.com/gentoo/sci/pull/1216 Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
Diffstat (limited to 'sci-physics/pyhf/pyhf-0.7.3.ebuild')
-rw-r--r--sci-physics/pyhf/pyhf-0.7.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-physics/pyhf/pyhf-0.7.3.ebuild b/sci-physics/pyhf/pyhf-0.7.3.ebuild
new file mode 100644
index 000000000..8b2d02304
--- /dev/null
+++ b/sci-physics/pyhf/pyhf-0.7.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_11 )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pure-python fitting/limit-setting/interval estimation HistFactory-style"
+HOMEPAGE="
+ https://github.com/scikit-hep/pyhf
+ https://doi.org/10.5281/zenodo.1169739
+ https://zenodo.org/record/8256635
+ https://doi.org/10.21105/joss.02823
+ https://inspirehep.net/literature/2598491
+ https://arxiv.org/abs/2211.15838
+ https://doi.org/10.22323/1.414.0245
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.5.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4.56.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.15.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonpatch-1.15[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"