aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2022-12-30 17:44:20 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-01-03 19:08:52 +0100
commita9d839cd446a33841bf0acb9ae5d3db2bf5cf5bc (patch)
treef44fa3d861e2762cc7f99e8f01678bdea790cdfd /sys-cluster
parentsys-cluster/modules: strong blocked lmod (diff)
downloadsci-a9d839cd446a33841bf0acb9ae5d3db2bf5cf5bc.tar.gz
sci-a9d839cd446a33841bf0acb9ae5d3db2bf5cf5bc.tar.bz2
sci-a9d839cd446a33841bf0acb9ae5d3db2bf5cf5bc.zip
sys-cluster/modules: update EAPI 7 -> 8
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Closes: https://github.com/gentoo/sci/pull/1189 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/modules/metadata.xml2
-rw-r--r--sys-cluster/modules/modules-4.6.0-r1.ebuild6
2 files changed, 5 insertions, 3 deletions
diff --git a/sys-cluster/modules/metadata.xml b/sys-cluster/modules/metadata.xml
index a67a56343..4842f7c2c 100644
--- a/sys-cluster/modules/metadata.xml
+++ b/sys-cluster/modules/metadata.xml
@@ -18,6 +18,8 @@
</longdescription>
<upstream>
<remote-id type="sourceforge">modules</remote-id>
+ <remote-id type="github">cea-hpc/modules</remote-id>
+ <bugs-to>https://github.com/cea-hpc/modules/issues</bugs-to>
</upstream>
<use>
<flag name="compat">Build Modules version 3 compat support</flag>
diff --git a/sys-cluster/modules/modules-4.6.0-r1.ebuild b/sys-cluster/modules/modules-4.6.0-r1.ebuild
index c7450c636..c6ecedf73 100644
--- a/sys-cluster/modules/modules-4.6.0-r1.ebuild
+++ b/sys-cluster/modules/modules-4.6.0-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit autotools python-single-r1
@@ -27,7 +27,7 @@ DEPEND="
# lmod is strong blocked since both want to install a module binary
RDEPEND="
${DEPEND}
- !!sys-cluster/lmod
+ !sys-cluster/lmod
"
BDEPEND="
test? ( dev-util/dejagnu )