aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-02-16 20:46:57 +0100
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-02-16 20:46:57 +0100
commitffab1c746c92ae11906fa242fc04840757c3dfc8 (patch)
tree97668e81376a35b787d5da9351062ed53aac8e1e /sys-cluster
parentdev-python/photutils: updated scikit-image package category (diff)
downloadsci-ffab1c746c92ae11906fa242fc04840757c3dfc8.tar.gz
sci-ffab1c746c92ae11906fa242fc04840757c3dfc8.tar.bz2
sci-ffab1c746c92ae11906fa242fc04840757c3dfc8.zip
sys-cluster/easybuild-framework: add 4.9.0, 9999
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/easybuild-framework/Manifest1
-rw-r--r--sys-cluster/easybuild-framework/easybuild-framework-4.9.0.ebuild40
-rw-r--r--sys-cluster/easybuild-framework/easybuild-framework-9999.ebuild40
3 files changed, 81 insertions, 0 deletions
diff --git a/sys-cluster/easybuild-framework/Manifest b/sys-cluster/easybuild-framework/Manifest
index 633cd3bdc..6845b4e9c 100644
--- a/sys-cluster/easybuild-framework/Manifest
+++ b/sys-cluster/easybuild-framework/Manifest
@@ -1 +1,2 @@
DIST easybuild-framework-4.6.2.tar.gz 2019284 BLAKE2B a32ae1fc43d490b32fc6c44790493204de935d16257846ec46830fc4d18a7343b860317c0ba33a16d89f12f657c33f7bb7359a70bf26a17c4e0dd16b8c78e2cd SHA512 ac8a06301c6c95edded262cb55b02ea8ada9ea14dfb7b7354a3bb29fcd9ad9a8d0011edbf2175085b8cec721f08a2b5f5e74aaa191d381a787eb5438c6c7f8cc
+DIST easybuild-framework-4.9.0.tar.gz 2064113 BLAKE2B 637498e7d52f0e9a6e9bd25c843052d9fc3c730f93b40c37381263b8861b0dd1b8ebf1d13af514d841d43284eb81b7555fcdaacbc1ac2c1bd655748c01540677 SHA512 b7b52d8987f13d9f859df0874adb7b855f8b4961215d9e9cb4a63a15911affe1591d718076277419be0c31e76845cf5cbe4fe553676ac71b8ff33a82d3c17a0e
diff --git a/sys-cluster/easybuild-framework/easybuild-framework-4.9.0.ebuild b/sys-cluster/easybuild-framework/easybuild-framework-4.9.0.ebuild
new file mode 100644
index 000000000..56dda1fba
--- /dev/null
+++ b/sys-cluster/easybuild-framework/easybuild-framework-4.9.0.ebuild
@@ -0,0 +1,40 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1
+
+DESCRIPTION="The easybuild-framework package is the core of EasyBuild."
+HOMEPAGE="
+ https://easybuild.io/
+ https://github.com/easybuilders/easybuild-framework
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/easybuilders/easybuild-framework"
+else
+ inherit pypi
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/autopep8[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/archspec[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.6.2-test.patch
+)
diff --git a/sys-cluster/easybuild-framework/easybuild-framework-9999.ebuild b/sys-cluster/easybuild-framework/easybuild-framework-9999.ebuild
new file mode 100644
index 000000000..56dda1fba
--- /dev/null
+++ b/sys-cluster/easybuild-framework/easybuild-framework-9999.ebuild
@@ -0,0 +1,40 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1
+
+DESCRIPTION="The easybuild-framework package is the core of EasyBuild."
+HOMEPAGE="
+ https://easybuild.io/
+ https://github.com/easybuilders/easybuild-framework
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/easybuilders/easybuild-framework"
+else
+ inherit pypi
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/autopep8[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/archspec[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.6.2-test.patch
+)