aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/snakemake-interface-storage-plugins/snakemake-interface-storage-plugins-3.2.3.ebuild')
-rw-r--r--dev-python/snakemake-interface-storage-plugins/snakemake-interface-storage-plugins-3.2.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/snakemake-interface-storage-plugins/snakemake-interface-storage-plugins-3.2.3.ebuild b/dev-python/snakemake-interface-storage-plugins/snakemake-interface-storage-plugins-3.2.3.ebuild
new file mode 100644
index 000000000..39c8b08a2
--- /dev/null
+++ b/dev-python/snakemake-interface-storage-plugins/snakemake-interface-storage-plugins-3.2.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit pypi distutils-r1
+
+DESCRIPTION="Stable interface for interactions between Snakemake and its storage plugins"
+HOMEPAGE="https://pypi.org/project/snakemake-interface-storage-plugins/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-python/snakemake-interface-common[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/reretry[${PYTHON_USEDEP}]
+ dev-python/throttler[${PYTHON_USEDEP}]"
+
+RESTRICT="test" # no tests collected
+#distutils_enable_tests pytest