summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2007-05-21 08:46:17 +0000
committerJakub Moc <jakub@gentoo.org>2007-05-21 08:46:17 +0000
commit11626752be8afdab8b7784cbdce20244252489b2 (patch)
treecadc87176c8c1d3fe184513a3755f37465b629d8 /app-antivirus
parentapp-antivirus/clamtk: Version bump (diff)
downloadsunrise-reviewed-11626752be8afdab8b7784cbdce20244252489b2.tar.gz
sunrise-reviewed-11626752be8afdab8b7784cbdce20244252489b2.tar.bz2
sunrise-reviewed-11626752be8afdab8b7784cbdce20244252489b2.zip
app-antivirus/xfprot: Version bump
svn path=/sunrise/; revision=3703
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/xfprot/ChangeLog3
-rw-r--r--app-antivirus/xfprot/Manifest4
-rw-r--r--app-antivirus/xfprot/xfprot-1.20.ebuild67
3 files changed, 73 insertions, 1 deletions
diff --git a/app-antivirus/xfprot/ChangeLog b/app-antivirus/xfprot/ChangeLog
index 66e3d2e4a..7ded74456 100644
--- a/app-antivirus/xfprot/ChangeLog
+++ b/app-antivirus/xfprot/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 21 May 2007; Jakub Moc <jakub@gentoo.org> +xfprot-1.20.ebuild:
+ Version bump
+
24 Mar 2007; Jakub Moc <jakub@gentoo.org> -xfprot-1.18.ebuild,
+xfprot-1.19.ebuild:
Version bump, nuke old
diff --git a/app-antivirus/xfprot/Manifest b/app-antivirus/xfprot/Manifest
index 9cc24ca32..c51794470 100644
--- a/app-antivirus/xfprot/Manifest
+++ b/app-antivirus/xfprot/Manifest
@@ -1,4 +1,6 @@
DIST xfprot-1.19.tar.gz 106518 RMD160 6e79423e07a0c09afc77cc0854a2c48ae863b69d SHA1 12d165cce5eee15f5fa29e7d763388ba3e4ba85c SHA256 33de53361c3b28c5a98c55a2604a73b8a37ce9025bb76c6fe1a534014d0b865f
+DIST xfprot-1.20.tar.gz 111546 RMD160 7be2cfd6ea9733b1cc1c754737b59b21849deb38 SHA1 76ca9c75969122fef92f69f7f3e0be7a5bc3fa5c SHA256 82c548a0c9a20057e0fa6e484f3f448c2e300815d3b427069bbd62a532271c98
EBUILD xfprot-1.19.ebuild 2066 RMD160 8b53b3eeae41d270aafe5d89f821e801fcefeab8 SHA1 174c521ef720baca290edaa01630a08f61c956e1 SHA256 d7db742ca0fa86fc06683096576797354afb45ce6990a94bd2961762a9279f27
-MISC ChangeLog 844 RMD160 ac2d8885d56a049e87731aebf5490a806ed4b892 SHA1 51f9e832e96175de480a362454018520b21ac590 SHA256 a47e0d96aa62bd21b0e870a58d41d49575cb6b514f6e22b438e905476225bb9d
+EBUILD xfprot-1.20.ebuild 2066 RMD160 8b53b3eeae41d270aafe5d89f821e801fcefeab8 SHA1 174c521ef720baca290edaa01630a08f61c956e1 SHA256 d7db742ca0fa86fc06683096576797354afb45ce6990a94bd2961762a9279f27
+MISC ChangeLog 925 RMD160 2eff618ac2621e82a7dc963302330171ea860bb7 SHA1 10c671c54d3e3fe790dea1b448b9e6ac430f8009 SHA256 20503a6f63bf013299722f9ffbff4adf8d81988ac7f2bb506339ea5433aee5ce
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/app-antivirus/xfprot/xfprot-1.20.ebuild b/app-antivirus/xfprot/xfprot-1.20.ebuild
new file mode 100644
index 000000000..9dacd5311
--- /dev/null
+++ b/app-antivirus/xfprot/xfprot-1.20.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="A graphical frontend to the F-Prot Antivirus(TM) for Linux"
+HOMEPAGE="http://web.tiscali.it/sharp/xfprot/"
+SRC_URI="http://web.tiscali.it/sharp/xfprot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE_LINGUAS="linguas_de linguas_en linguas_es linguas_fr linguas_it linguas_pl linguas_pt_BR"
+IUSE="${IUSE_LINGUAS} debug"
+
+DEPEND=">=x11-libs/gtk+-2.4
+ >=app-antivirus/f-prot-4.6.0-r2"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ einfo "Please, set your LINGUAS to exactly ONE of the supported values."
+ einfo "This application cannot support multiple languages at the same time (yet)."
+}
+
+src_compile() {
+ local myconf=
+ use linguas_de && myconf="${myconf} --with-lang=de_DE"
+ use linguas_en && myconf="${myconf} --with-lang=en_GB"
+ use linguas_es && myconf="${myconf} --with-lang=es_ES"
+ use linguas_fr && myconf="${myconf} --with-lang=fr_FR"
+ use linguas_it && myconf="${myconf} --with-lang=it_IT"
+ use linguas_pl && myconf="${myconf} --with-lang=pl_PL"
+ use linguas_pt_BR && myconf="${myconf} --with-lang=pt_BR"
+
+ if [[ -z ${myconf} ]] ; then
+ einfo "You didn't select any language, defaulting to English."
+ einfo "If you want something else, set LINGUAS accordingly."
+ epause 3
+ myconf="--with-lang=en_GB"
+ fi
+
+ # not using econf because script does not like --prefix=/usr
+ ./configure \
+ --autodetect \
+ --with-install-dir="${D}/usr" \
+ ${myconf} \
+ $(use_with debug) || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ # install manually, make install produces stupid directory structure
+ newbin ${S}/xfprot-gtk xfprot
+
+ # Install the icons
+ insinto /usr/share/pixmaps
+ newins icons/antivirus-32x32.png xfprot.png
+ for res in 32x32 48x48 64x64 128x128 ; do
+ insinto /usr/share/icons/hicolor/${res}/apps/
+ newins icons/antivirus-${res}.png xfprot.png
+ done
+ make_desktop_entry ${PN} "XFProt (F-Prot AV GUI)" ${PN}.png "Security;System;GTK"
+
+ dodoc Changelog README eicar.com.txt
+}