summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/ggencoder/ggencoder-0.91a.ebuild')
-rw-r--r--games-util/ggencoder/ggencoder-0.91a.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-util/ggencoder/ggencoder-0.91a.ebuild b/games-util/ggencoder/ggencoder-0.91a.ebuild
new file mode 100644
index 000000000..aacf506b6
--- /dev/null
+++ b/games-util/ggencoder/ggencoder-0.91a.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+inherit eutils qt4
+
+DESCRIPTION="Utility to encode and decode Game Genie (tm) codes."
+HOMEPAGE="http://games.technoplaza.net/ggencoder/qt/"
+SRC_URI="http://games.technoplaza.net/${PN}/qt/history/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="x11-libs/qt-core:4
+ x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+
+S="${S}/source"
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed"
+
+ cd ..
+ dodoc docs/ggencoder.txt || die "dodoc failed"
+
+ if use doc ; then
+ dohtml -r apidocs/html/* || die "dohtml failed"
+ fi
+}
+