summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArne Babenhauserheide (ArneBab) <arne_bab@web.de>2010-09-13 15:52:01 +0000
committerArne Babenhauserheide (ArneBab) <arne_bab@web.de>2010-09-13 15:52:01 +0000
commitbb8bc9ddc146fc1651a202ff215d43622874096c (patch)
tree995e484ad7c8cfe20512cb5a15ed14560bb80d6b /dev-vcs
parentdev-db/pgbouncer: Version bump (diff)
downloadsunrise-bb8bc9ddc146fc1651a202ff215d43622874096c.tar.gz
sunrise-bb8bc9ddc146fc1651a202ff215d43622874096c.tar.bz2
sunrise-bb8bc9ddc146fc1651a202ff215d43622874096c.zip
dev-vcs/tortoisehg: New Ebuild for bug 277383 thanks to manny15, Tommy[D] and apostrophe
svn path=/sunrise/; revision=11311
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/ChangeLog8
-rw-r--r--dev-vcs/tortoisehg/Manifest4
-rw-r--r--dev-vcs/tortoisehg/metadata.xml14
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-1.1.3.ebuild51
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
new file mode 100644
index 000000000..137dcaa30
--- /dev/null
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-vcs/tortoisehg
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 13 Sep 2010; Arne Babenhauserheide (ArneBab) <arne_bab@web.de>
+ +tortoisehg-1.1.3.ebuild, +metadata.xml:
+ New Ebuild for bug 277383 thanks to manny15, Tommy[D] and apostrophe
+
diff --git a/dev-vcs/tortoisehg/Manifest b/dev-vcs/tortoisehg/Manifest
new file mode 100644
index 000000000..b16e528a1
--- /dev/null
+++ b/dev-vcs/tortoisehg/Manifest
@@ -0,0 +1,4 @@
+DIST tortoisehg-1.1.3.tar.gz 6579300 RMD160 8c94e4c03415bb1ab3385c33dc0d6f1470bb0310 SHA1 01a0532edfa9db12f4b1ce003d4be9e53a426abf SHA256 8207cbbcac82bc405a7be41bd91795267b242dd3fbdfa10c80174a6ed278a75c
+EBUILD tortoisehg-1.1.3.ebuild 1129 RMD160 b8887d98f731f92b25df8f50b018f03acd3c73aa SHA1 c512a4958198709371a6758a4e44c989fd782f6e SHA256 0066b4c2782ac0be38488e8147c9973618931eb83d926e0517735ff226ac8d39
+MISC ChangeLog 299 RMD160 7e3955b169b4d0eae6b9d17dde69595f83b0f2be SHA1 f97db48dd78c156852fbcd68ab4cf9a1d1595e6d SHA256 ed62ae420466ef8452e68db4aa78229e09e5d731c48267c1539a3650c7a67c32
+MISC metadata.xml 562 RMD160 05d38eb0c4d143b23f201fce2802285bbce0beec SHA1 4ec7a99032635e139a5f08a98a19b2b9eac5a251 SHA256 398a77872f8420c1e024c1c978f6f69af19bc7e0ff048a76b9ba80ee8b361f90
diff --git a/dev-vcs/tortoisehg/metadata.xml b/dev-vcs/tortoisehg/metadata.xml
new file mode 100644
index 000000000..2849f3b46
--- /dev/null
+++ b/dev-vcs/tortoisehg/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <longdescription lang="en">
+ Graphical cross-platform frontend to various Mercurial commands.
+ Currently contains dialogs for almost all common operations,
+ including annotate and log.
+ </longdescription>
+ <use>
+ <flag name="nautilus">Integrate with <pkg>gnome-base/nautilus</pkg> file manager</flag>
+ </use>
+ <maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/dev-vcs/tortoisehg/tortoisehg-1.1.3.ebuild b/dev-vcs/tortoisehg/tortoisehg-1.1.3.ebuild
new file mode 100644
index 000000000..d236dc759
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-1.1.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2:2.6"
+RESTRICT_PYTHON_ABIS="2.[45] 3.*"
+
+inherit distutils
+
+DESCRIPTION="Mercurial GUI command line tool hgtk"
+HOMEPAGE="http://tortoisehg.bitbucket.org"
+SRC_URI="http://bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc nautilus"
+
+DEPEND="doc? ( >=dev-python/sphinx-1.0.3 )"
+RDEPEND="dev-python/pygtk
+ >=dev-vcs/mercurial-1.6.3
+ >=dev-python/iniparse-0.4
+ nautilus? ( dev-python/nautilus-python )"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ emake -C doc html || die
+ fi
+}
+
+src_install() {
+ # make the install respect multilib.
+ sed -i -e "s:lib/nautilus/extensions-2.0/python:$(get_libdir)/nautilus/extensions-2.0/python:" setup.py || die
+
+ distutils_src_install
+ dodoc doc/ReadMe*.txt doc/TODO || die
+
+ if use doc ; then
+ dohtml -r doc/build/html || die
+ fi
+
+ if ! use nautilus; then
+ einfo "Excluding Nautilus extension."
+ rm -fR "${D}"/usr/$(get_libdir)/nautilus || die
+ fi
+} \ No newline at end of file