summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2009-09-21 20:51:33 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2009-09-21 20:51:33 +0000
commit0dbbf2ff1e1ededefb67c2f161cd08a2297c07b7 (patch)
tree482c0f7ba6f5c87f538daa8c6f6cb483e9605650 /sci-chemistry/bist/bist-0.5.1.ebuild
parentapp-forensics/yim2text: Keyword ~amd64 per request in bug 268519 (diff)
downloadsunrise-0dbbf2ff1e1ededefb67c2f161cd08a2297c07b7.tar.gz
sunrise-0dbbf2ff1e1ededefb67c2f161cd08a2297c07b7.tar.bz2
sunrise-0dbbf2ff1e1ededefb67c2f161cd08a2297c07b7.zip
sci-chemistry/bist: Version bump and upgrade of the ebuild to EAPI=2
svn path=/sunrise/; revision=9274
Diffstat (limited to 'sci-chemistry/bist/bist-0.5.1.ebuild')
-rw-r--r--sci-chemistry/bist/bist-0.5.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-chemistry/bist/bist-0.5.1.ebuild b/sci-chemistry/bist/bist-0.5.1.ebuild
new file mode 100644
index 000000000..b028cd386
--- /dev/null
+++ b/sci-chemistry/bist/bist-0.5.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Bist, the chemical drawing tool"
+HOMEPAGE="http://www.autistici.org/interzona/index.php?mod=03_Bist"
+SRC_URI="http://www.autistici.org/interzona/ftrack.php?url=sections/06_Download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-misc/curl
+ dev-libs/expat
+ >=x11-libs/fltk-1.1.7:1.1
+ sci-libs/gsl
+ >=sci-chemistry/openbabel-2.2.0
+ >=media-libs/plotutils-2.5"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ use amd64 && epatch "${FILESDIR}/wrap_bracket_dialog-amd64.patch"
+}
+
+src_install() {
+ dobin bist || die "bist install failed"
+
+ #install bist plug-ins
+ insinto /usr/lib/bist/plugin
+ doins plugin/*.so || die "make plugin failed"
+
+ dodoc AUTHORS TODO || die
+ cd doc
+ doman man/bist.1 || die
+ dohtml *.html *.png *jpg || die
+}