summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Szymaniak (lazy_bum) <szarpaj@grubelek.pl>2014-10-13 22:09:40 +0200
committerPiotr Szymaniak (lazy_bum) <szarpaj@grubelek.pl>2014-10-13 22:09:44 +0200
commitf6a06ff9a1d7ae2b56df28dbeefbbf0beee5faac (patch)
tree9f3818ad90eb7ee8b56b8301fa403d87e2327843 /sys-fs/cromfs/cromfs-1.5.10.2.ebuild
parent[dev-perl/Net-IPv4Addr] Available in tree. (diff)
downloadsunrise-f6a06ff9a1d7ae2b56df28dbeefbbf0beee5faac.tar.gz
sunrise-f6a06ff9a1d7ae2b56df28dbeefbbf0beee5faac.tar.bz2
sunrise-f6a06ff9a1d7ae2b56df28dbeefbbf0beee5faac.zip
sys-fs/cromfs: Version bump.
Diffstat (limited to 'sys-fs/cromfs/cromfs-1.5.10.2.ebuild')
-rw-r--r--sys-fs/cromfs/cromfs-1.5.10.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-fs/cromfs/cromfs-1.5.10.2.ebuild b/sys-fs/cromfs/cromfs-1.5.10.2.ebuild
new file mode 100644
index 000000000..b99ed9c57
--- /dev/null
+++ b/sys-fs/cromfs/cromfs-1.5.10.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="a FUSE based compressed read-only filesystem for Linux."
+HOMEPAGE="http://bisqwit.iki.fi/source/cromfs.html"
+SRC_URI="http://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="static"
+
+DEPEND=">=sys-fs/fuse-2.5.2"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ sed -i -e '/upx/d' -e '/- strip/d' Makefile || \
+ die "sed failed to remove UPX and strip."
+ econf
+ emake || die "Make failed."
+}
+
+src_install() {
+ if use static; then
+ dobin cromfs-driver-static || \
+ die "Couldn't find the static binary to install."
+ fi
+ dobin cromfs-driver util/mkcromfs util/unmkcromfs util/cvcromfs || \
+ die "Some binaries failed to install."
+ dodoc doc/*.txt doc/FORMAT doc/ChangeLog || die "dodoc failed"
+ dohtml doc/*.html doc/*.png || die "dohtml failed"
+}