summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Matzkov (bapa) <bapabooiee@gmail.com>2010-10-28 15:03:19 +0000
committerDean Matzkov (bapa) <bapabooiee@gmail.com>2010-10-28 15:03:19 +0000
commit2a27a9a2787438b350f643152f1fbd6411f0f156 (patch)
tree8c03d3172b4836254e4dfb6c4ad9cb91d2362c28 /x11-plugins
parentnet-analyzer/icinga: fixup of enewuser (typo, missing a -1) (diff)
downloadsunrise-2a27a9a2787438b350f643152f1fbd6411f0f156.tar.gz
sunrise-2a27a9a2787438b350f643152f1fbd6411f0f156.tar.bz2
sunrise-2a27a9a2787438b350f643152f1fbd6411f0f156.zip
x11-plugins/pidgin-gfire: New ebuild for bug #252548, with thanks to Andrzej Kardas for his initial work
svn path=/sunrise/; revision=11497
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-gfire/ChangeLog8
-rw-r--r--x11-plugins/pidgin-gfire/Manifest4
-rw-r--r--x11-plugins/pidgin-gfire/metadata.xml6
-rw-r--r--x11-plugins/pidgin-gfire/pidgin-gfire-0.9.2.ebuild49
4 files changed, 67 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-gfire/ChangeLog b/x11-plugins/pidgin-gfire/ChangeLog
new file mode 100644
index 000000000..993a3dc53
--- /dev/null
+++ b/x11-plugins/pidgin-gfire/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for x11-plugins/pidgin-gfire
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 28 Oct 2010; Dean Matzkov (bapa) <bapabooiee@gmail.com>
+ +pidgin-gfire-0.9.2.ebuild, +metadata.xml:
+ New ebuild for bug #252548, with thanks to Andrzej Kardas for his initial work
+
diff --git a/x11-plugins/pidgin-gfire/Manifest b/x11-plugins/pidgin-gfire/Manifest
new file mode 100644
index 000000000..80e89f89f
--- /dev/null
+++ b/x11-plugins/pidgin-gfire/Manifest
@@ -0,0 +1,4 @@
+DIST pidgin-gfire-0.9.2.tar.bz2 494341 RMD160 c536b5c170c2c16c47a39efe5a5a060fdfecdbd2 SHA1 c26026462d6e29c0c9900ac7734df4b3cdbadcbc SHA256 02ddf8ae5f5a9593d2395639ded119d3760184c3659b1f45688e6b3f2ff1230f
+EBUILD pidgin-gfire-0.9.2.ebuild 1165 RMD160 3a2a5cd6eb47a1953699f1d2e1df4303a2c269b1 SHA1 0854394a50b12c3e85ae913081968a609404cf5a SHA256 a276de0c08186855e19089f6b7f467f5e86a57a35555934c0e370c630dd84a6b
+MISC ChangeLog 310 RMD160 286b0a09cba75d871903584874a4da326fafe3ca SHA1 c913c23003560ded83304e2522e1bd3f24d4f558 SHA256 4d2ee7f8a252ad4059842bd43070714bf52775f3bb3fa6dd87f683885b878f01
+MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/x11-plugins/pidgin-gfire/metadata.xml b/x11-plugins/pidgin-gfire/metadata.xml
new file mode 100644
index 000000000..e6233b5dc
--- /dev/null
+++ b/x11-plugins/pidgin-gfire/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/x11-plugins/pidgin-gfire/pidgin-gfire-0.9.2.ebuild b/x11-plugins/pidgin-gfire/pidgin-gfire-0.9.2.ebuild
new file mode 100644
index 000000000..5460634f6
--- /dev/null
+++ b/x11-plugins/pidgin-gfire/pidgin-gfire-0.9.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+DESCRIPTION="Pidgin plugin for adding Xfire accounts and connecting to the Xfire network"
+HOMEPAGE="http://gfireproject.org/"
+SRC_URI="mirror://sourceforge/gfire/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug dbus gtk libnotify nls"
+
+RDEPEND="
+ net-im/pidgin[gtk?]
+ dbus? ( dev-libs/dbus-glib )
+ gtk? ( x11-libs/gtk+:2 )
+ libnotify? ( x11-libs/libnotify )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ local myconf=$(use_enable libnotify)
+
+ if use libnotify && ! use gtk; then
+ ewarn "libnotify requires GTK support to be enabled; libnotify disabled"
+ myconf="--disable-libnotify"
+ fi
+
+ econf \
+ $(use_enable dbus dbus-status) \
+ $(use_enable debug) \
+ $(use_enable gtk) \
+ $(use_enable nls) \
+ ${myconf}
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS README ChangeLog || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "Please note that, unlike other Pidgin plugins, the Gfire plugin"
+ elog "requires Pidgin to be restarted before it is used"
+}