summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-21 05:38:00 +0000
committerSam James <sam@gentoo.org>2022-07-22 20:36:46 +0000
commit4f26ab54a0cb90964360b2e99001e395b4bad778 (patch)
tree625a84e4d27b7d123bb358e734bb60cf6b79901f /sys-devel/gcc/gcc-4.8.2.ebuild
parentdrop outdated packages (diff)
downloadtoolchain-4f26ab54a0cb90964360b2e99001e395b4bad778.tar.gz
toolchain-4f26ab54a0cb90964360b2e99001e395b4bad778.tar.bz2
toolchain-4f26ab54a0cb90964360b2e99001e395b4bad778.zip
Revert "drop outdated packages"
This reverts commit ba79ef07c9aea05907210217ee8bcb705e43c8c7. The overlay exists for older versions of toolchain packages and the commit being reverted removed every single ebuild from the overlay. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/gcc/gcc-4.8.2.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.8.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-4.8.2.ebuild b/sys-devel/gcc/gcc-4.8.2.ebuild
new file mode 100644
index 0000000..f2c3cd3
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.8.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.3r1"
+UCLIBC_VER="1.0"
+
+# Hardened gcc 4 stuff
+PIE_VER="0.5.8r1"
+SPECS_VER="0.2.0"
+SPECS_GCC_VER="4.4.3"
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+PIE_GLIBC_STABLE="x86 amd64 mips ppc ppc64 arm ia64"
+PIE_UCLIBC_STABLE="x86 arm amd64 mips ppc ppc64"
+SSP_STABLE="amd64 x86 mips ppc ppc64 arm"
+# uclibc need tls and nptl support for SSP support
+# uclibc need to be >= 0.9.33
+SSP_UCLIBC_STABLE="x86 amd64 mips ppc ppc64 arm"
+#end Hardened stuff
+
+inherit toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_prepare() {
+ if has_version '<sys-libs/glibc-2.12' ; then
+ ewarn "Your host glibc is too old; disabling automatic fortify."
+ ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
+ EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+ fi
+
+ toolchain_src_prepare
+}