summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-06-29 19:05:16 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-06-29 19:05:16 +0200
commit1fec9188faca01b3a679ec42cf74c638d4b34ebd (patch)
treed16739ea15863e18ecc127be19e5d2cacae05e2e /9999/0001-Gentoo-libiberty-install-PIC-version-of-libiberty.a.patch
parentLet's try without poison (diff)
downloadbinutils-patches-1fec9188faca01b3a679ec42cf74c638d4b34ebd.tar.gz
binutils-patches-1fec9188faca01b3a679ec42cf74c638d4b34ebd.tar.bz2
binutils-patches-1fec9188faca01b3a679ec42cf74c638d4b34ebd.zip
Renumber patches
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to '9999/0001-Gentoo-libiberty-install-PIC-version-of-libiberty.a.patch')
-rw-r--r--9999/0001-Gentoo-libiberty-install-PIC-version-of-libiberty.a.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/9999/0001-Gentoo-libiberty-install-PIC-version-of-libiberty.a.patch b/9999/0001-Gentoo-libiberty-install-PIC-version-of-libiberty.a.patch
new file mode 100644
index 0000000..a36bb51
--- /dev/null
+++ b/9999/0001-Gentoo-libiberty-install-PIC-version-of-libiberty.a.patch
@@ -0,0 +1,34 @@
+From 1594a93229b13d3c34c679e5991e64663cace1b9 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Fri, 7 Jan 2005 00:15:53 -0500
+Subject: [PATCH 2/7] Gentoo: libiberty: install PIC version of libiberty.a
+
+This will install a PIC version of libiberty.a by overwriting the non-PIC
+version of libiberty.a while compiling. We do this because there is no
+shared version of libiberty for random apps to link against which means if
+someone wants to use this in a shared library or PIE, they're out of luck.
+It's arguable whether people should be able to use this in a shared lib,
+but usage in PIE should be fine. You could argue that this penalizes the
+non-PIE users, but the counter point is that people using this library in
+general are fairly low, and we'd rather have things work for all of them.
+
+(cherry picked from commit 112aff9ad3e2675556370c4281117a6df0a879d9)
+---
+ libiberty/Makefile.in | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libiberty/Makefile.in b/libiberty/Makefile.in
+index b77a41c781c..5e3725d16ff 100644
+--- a/libiberty/Makefile.in
++++ b/libiberty/Makefile.in
+@@ -258,6 +258,7 @@ $(TARGETLIB): $(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS)
+ $(AR) $(AR_FLAGS) $(TARGETLIB) \
+ $(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS); \
+ $(RANLIB) $(TARGETLIB); \
++ cp $(TARGETLIB) ../ ; \
+ cd ..; \
+ else true; fi; \
+ if [ x"$(NOASANFLAG)" != x ]; then \
+--
+2.44.2
+