aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py37
1 files changed, 37 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..1ea369a
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,37 @@
+#!/usr/bin/env python
+
+from setuptools import setup
+
+# Version info -- read without importing
+_locals = {}
+with open("tyrian_sphinx_theme/_version.py") as fp:
+ exec(fp.read(), None, _locals)
+version = _locals["__version__"]
+
+setup(
+ name="tyrian-sphinx-theme",
+ version=version,
+ description="A Tyrian based Sphinx theme for Gentoo",
+ long_description=open('README.rst', encoding='utf-8').read(),
+ author="Max Magorsch",
+ author_email="max@magorsch.de",
+ url="https://github.com/mmagorsc/tyrian_sphinx_theme",
+ packages=["tyrian_sphinx_theme"],
+ include_package_data=True,
+ entry_points={"sphinx.html_themes": ["tyrian_sphinx_theme = tyrian_sphinx_theme"]},
+ classifiers=[
+ "Framework :: Sphinx",
+ "Framework :: Sphinx :: Theme",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6"
+ ],
+) \ No newline at end of file