summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2015-02-13 22:33:40 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2015-02-13 22:33:40 +0100
commitd110b2d653d2e4ef4f89c4c19152b6a2d034c597 (patch)
tree2b86add6fd9812553ccc9409ab41833d544b4fb5
parenthg snapshot 2014/11/16; need testing before main tree (diff)
downloaddevel-d110b2d653d2e4ef4f89c4c19152b6a2d034c597.tar.gz
devel-d110b2d653d2e4ef4f89c4c19152b6a2d034c597.tar.bz2
devel-d110b2d653d2e4ef4f89c4c19152b6a2d034c597.zip
initial commit
-rw-r--r--media-plugins/vdr-dvbapi/Manifest3
-rw-r--r--media-plugins/vdr-dvbapi/metadata.xml10
-rw-r--r--media-plugins/vdr-dvbapi/vdr-dvbapi-2.1.1.ebuild78
3 files changed, 91 insertions, 0 deletions
diff --git a/media-plugins/vdr-dvbapi/Manifest b/media-plugins/vdr-dvbapi/Manifest
new file mode 100644
index 0000000..2711945
--- /dev/null
+++ b/media-plugins/vdr-dvbapi/Manifest
@@ -0,0 +1,3 @@
+DIST vdr-dvbapi-2.1.1.tar.gz 82813 SHA256 2724768de00a607d7119478296a3ad1cc592c12badbc95480edc5f7e6b3985d7 SHA512 fb632e66c9e477663eb1edf5e630a20b2165495c89d5bd6294d74d6a28c8386021d90914c9c6b958ea3c5c1d0958cc69efa5c65ef72c510c224d676f1eca39ae WHIRLPOOL af18c22bb00ddbb41aa8e3ee091f27a1bb7b79f0d90783af9c9503ad03a568193c88cc41db86e0e06fd8c503ad43242a582b0decc5f64c417283517f05d14727
+EBUILD vdr-dvbapi-2.1.1.ebuild 2543 SHA256 1f8e16309e7cacf05c055402d5cad4883938e733a98db9fb15a34705e907ad7d SHA512 59a3fda45d4d7dd3a312819af0118e287042c5aa172862f1b3b8d2224c738342b55638aa9efc3a0172a21f44fa166c1de1398e174d49225641c1bc54516edb61 WHIRLPOOL bbfb3a7fa94af327c8dcf55377366f0b7468c4bc851e1af9a212a205699b8fa0e0bddf3c10f88625e7ab37da89a7ec3403097bf43b01661a2573dbd01bf6d1c1
+MISC metadata.xml 255 SHA256 757dc0cac83321dea2752f2d82626ff3bc7ec640f528afd559f9e68edc54582d SHA512 5452a02781dbd11e8b2f8c0feea486d2ef623ecb3cefd215d701afdb37b75d16df35a2fffd516df33a52e97f651f08baf275dc139528cb1387e40117b60b259f WHIRLPOOL ef4a79e977c08a29435c927efbe75d48dec89e5512f1312058eb19414f2ed7ea441f1145d2780d45a0d0f9897d2a27d4792d11b5963f9e1d22283f6e5b005abd
diff --git a/media-plugins/vdr-dvbapi/metadata.xml b/media-plugins/vdr-dvbapi/metadata.xml
new file mode 100644
index 0000000..32917ab
--- /dev/null
+++ b/media-plugins/vdr-dvbapi/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>hd_brummy@gentoo.org</email>
+<name>Joerg Bornkessel</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-dvbapi/vdr-dvbapi-2.1.1.ebuild b/media-plugins/vdr-dvbapi/vdr-dvbapi-2.1.1.ebuild
new file mode 100644
index 0000000..3155fe4
--- /dev/null
+++ b/media-plugins/vdr-dvbapi/vdr-dvbapi-2.1.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: allows connect VDR to OScam"
+HOMEPAGE="https://github.com/manio/vdr-plugin-dvbapi"
+SRC_URI="https://github.com/manio/vdr-plugin-dvbapi/archive/v${PV}.tar.gz -> vdr-dvbapi-${PV}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2"
+
+DEPEND=">=media-video/vdr-2.1.4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/vdr-plugin-dvbapi-${PV}"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ # respect the system CXXFLAGS
+ sed -e "s:FLAGS:CXXFLAGS:" -i FFdecsa/Makefile
+
+ # Prepare flags for FFdeCSA
+ if [ -n "${VDR_DVBAPI_PARALLEL}" ]; then
+ PARALLEL="${VDR_DVBAPI_PARALLEL}"
+ else
+ # [32/64] Core2 (SSSE3) achieves best results with SSE2 & SSE
+ # [64] Athlon64 (SSE2) does much better with 64_LONG
+ # [32] Athlon64 (SSE2) does best with MMX
+ # [32] Pentium4 & Atom (SSE2) work best with SSE2 & SSE
+ # [32] AthlonXP (SSE) has MMX faster
+
+ # To avoid parsing -march=, we use ugly assumption that Intels don't
+ # have 3dnow and AMDs do. SSE achieves good results only on Intel CPUs,
+ # and LONG is best on 64-bit AMD CPUs.
+
+ if ! use cpu_flags_x86_3dnow && use cpu_flags_x86_sse2; then
+ PARALLEL=PARALLEL_128_SSE2
+ elif ! use cpu_flags_x86_3dnow && use cpu_flags_x86_sse; then
+ PARALLEL=PARALLEL_128_SSE
+ elif use amd64; then
+ PARALLEL=PARALLEL_64_LONG
+ elif use cpu_flags_x86_mmx; then
+ PARALLEL=PARALLEL_64_MMX
+ else
+ # fallback values:
+ # PARALLEL_32_INT fails with gcc4.4 on x86&amd64
+ # PARALLEL_64_2INT fails with gcc4.4 on x86
+ # PARALLEL_128_4INT seems to be the fastest non-failing fallback
+ PARALLEL=PARALLEL_128_4INT
+ fi
+
+ ewarn "VDR_DVBAPI_PARALLEL in your system make.conf is not set, guessing value from USEflags (${PARALLEL})."
+ ewarn "This setting may be suboptimal, so you'll probably want to tweak it yourself."
+ ewarn "\n\tRun the script ${WORKDIR}/extra/FFdecsa-benchmark.sh"
+ ewarn "\tand add the output parameter from PARALLEL= to your system make.conf"
+ ewarn "\tVDR_DVBAPI_PARALLEL= your parameter"
+ fi
+
+ export PARALLEL
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ elog "This software might be illegal in some countries or violate"
+ elog "rules of your DVB provider"
+ elog "Please respect these rules.\n"
+
+ elog "We do not offer support of any kind"
+ elog "Asking for keys or for installation help will be ignored by gentoo developers!\n"
+}