summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2005-12-03 08:08:16 +0000
committerBenedikt Boehm <hollow@gentoo.org>2005-12-03 08:08:16 +0000
commitc6820f33189edeec02e6f3976e739e017fffaec0 (patch)
treee48882f75d1533ccb8c6331bf9b026ada9ed02bf
parentImport the latest baselayout changes. Merging revision 1658. (diff)
downloadbaselayout-vserver-c6820f33189edeec02e6f3976e739e017fffaec0.tar.gz
baselayout-vserver-c6820f33189edeec02e6f3976e739e017fffaec0.tar.bz2
baselayout-vserver-c6820f33189edeec02e6f3976e739e017fffaec0.zip
we don't need this with new profiles
svn path=/baselayout-vserver/trunk/; revision=138
-rw-r--r--src/ovz-mount-proc/Makefile16
-rw-r--r--src/ovz-mount-proc/ovz-mount-proc.c25
2 files changed, 0 insertions, 41 deletions
diff --git a/src/ovz-mount-proc/Makefile b/src/ovz-mount-proc/Makefile
deleted file mode 100644
index 0859a49..0000000
--- a/src/ovz-mount-proc/Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-CC = gcc
-LD = gcc
-
-TARGETS = ovz-mount-proc
-
-all: $(TARGETS)
-
-ovz-mount-proc: ovz-mount-proc.o
- $(CC) -static -Wall -o $@ $^
-
-clean:
- rm -f $(TARGETS)
- rm -f *.o *~
diff --git a/src/ovz-mount-proc/ovz-mount-proc.c b/src/ovz-mount-proc/ovz-mount-proc.c
deleted file mode 100644
index 866bcf6..0000000
--- a/src/ovz-mount-proc/ovz-mount-proc.c
+++ /dev/null
@@ -1,25 +0,0 @@
-/* Simple prog to mount /proc inside a VPS.
- * Can be statically compiled with dietlibc:
- * diet -Os gcc -static -s -o mount.proc mount.proc.c
- *
- * By Kir Kolyshkin <kir-at-sw-dot-ru>.
- * Licensed under GNU GPL version 2.
- */
-
-#include <sys/mount.h>
-#include <sys/stat.h>
-#include <sys/types.h>
-
-/* Taken from /usr/src/linux/include/fs.h */
-#define MS_POSIXACL (1<<16) /* VFS does not apply the umask */
-#define MS_ACTIVE (1<<30)
-#define MS_NOUSER (1<<31)
-
-int main(void)
-{
- /* "Normal" mount uses the same flags, so should we... */
- unsigned long flags = MS_POSIXACL|MS_ACTIVE|MS_NOUSER|0xec0000;
-
- mkdir("/proc", 0755);
- return mount("none", "/proc", "proc", flags, 0);
-}