summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-11-05 10:27:04 +0000
committerChristian Heim <phreak@gentoo.org>2006-11-05 10:27:04 +0000
commit56d02a909bd8303d87402a78dde9abca71737fce (patch)
tree802a8db6da8c578c93e7f9199e11f5eb5d2c3f74
parentAdding Benedikt's updated init-scripts, deprecating the old one. (diff)
downloadmisc-56d02a909bd8303d87402a78dde9abca71737fce.tar.gz
misc-56d02a909bd8303d87402a78dde9abca71737fce.tar.bz2
misc-56d02a909bd8303d87402a78dde9abca71737fce.zip
Parts of 025_all_namespace-cleanup.patch slipped accidently into 005_all_baselayout-1.13.patch. Reverting that.
svn path=/; revision=521
-rw-r--r--util-vserver/patches/0.30.211-r1/005_all_baselayout-1.13.patch63
1 files changed, 0 insertions, 63 deletions
diff --git a/util-vserver/patches/0.30.211-r1/005_all_baselayout-1.13.patch b/util-vserver/patches/0.30.211-r1/005_all_baselayout-1.13.patch
index de318f7..782c3f1 100644
--- a/util-vserver/patches/0.30.211-r1/005_all_baselayout-1.13.patch
+++ b/util-vserver/patches/0.30.211-r1/005_all_baselayout-1.13.patch
@@ -32,69 +32,6 @@ Index: scripts/vserver.functions
(x) ;;
(*) panic "Unknown init-style '$INITSTYLE'; aborting";;
esac
-@@ -805,7 +825,7 @@
- _mountVserverInternal "$cfgdir"/fstab.remote $_CHBIND "${CHBIND_OPTS[@]}"
-
- isNamespaceCleanup "$cfgdir" && \
-- _namespaceCleanup
-+ _namespaceCleanup "$cfgdir"
-
- isAvoidNamespace "$cfgdir" || \
- $_SECURE_MOUNT --rbind -n "$vdir" "/"
-@@ -1161,26 +1181,39 @@
-
- function _namespaceCleanup
- {
-- local root=$(readlink -f "$vdir")
-- local tmp="$root"
-+ local vdir="$1"
-+ local root=$($_VSERVER_INFO "$1" VDIR 1)
- local -a list
-- while [ "$tmp" ]; do
-- list=( "${list[@]}" "$tmp" )
-- tmp="${tmp%/*}"
-+ local -a skip
-+ local tmp
-+
-+ getFileArray skip "$vdir"/namespace-cleanup-skip \
-+ "$__CONFDIR"/.defaults/namespace-cleanup-skip || :
-+
-+ # these are things that have to be accessible post-cleanup
-+ for tmp in "$root" "$__SBINDIR" "$__PKGLIBDIR" "$vdir" \
-+ "$__PKGSTATEDIR" "${skip[@]}"; do
-+ while test -n "$tmp"; do
-+ list=( "${list[@]}" "$tmp" )
-+ tmp="${tmp%/*}"
-+ done
- done
-+
- local -a list_umount
- while read dev path opts; do
-- [ "$path" ] || continue
-- for i in "$root" /dev /proc; do
-- [ "${path#$i}" != "$path" ] && continue 2
-- done
-- for i in "${list[@]}" /; do
-- [ "$path" = "$i" ] && continue 2
-- done
-- list_umount=( "${list_umount[@]}" "$path" )
-+ test -n "$path" || continue
-+ for i in "$root" /dev /proc; do
-+ test "${path#$i}" != "$path" && continue 2
-+ done
-+ for i in "${list[@]}" /; do
-+ test "$path" = "$i" && continue 2
-+ done
-+ # unmount them in reverse order so mounts further down the tree get unmounted first
-+ list_umount=( "$path" "${list_umount[@]}" )
- done < /proc/mounts
-+ # separate loop to avoid races while reading /proc/mounts
- for i in "${list_umount[@]}"; do
-- umount -l -n "$i"
-+ $_UMOUNT -l -n "$i"
- done
- }
-
Index: distrib/Makefile.am
===================================================================
--- distrib/Makefile.am (revision 2354)