summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/postfixadmin/postfixadmin-2.1.0-r2.ebuild')
-rw-r--r--net-mail/postfixadmin/postfixadmin-2.1.0-r2.ebuild32
1 files changed, 14 insertions, 18 deletions
diff --git a/net-mail/postfixadmin/postfixadmin-2.1.0-r2.ebuild b/net-mail/postfixadmin/postfixadmin-2.1.0-r2.ebuild
index 52a4373..fb79f9f 100644
--- a/net-mail/postfixadmin/postfixadmin-2.1.0-r2.ebuild
+++ b/net-mail/postfixadmin/postfixadmin-2.1.0-r2.ebuild
@@ -1,11 +1,7 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-# Source: http://bugs.gentoo.org/show_bug.cgi?id=50035
-# Submitted-By: SteveB <tp22a@softhome.net>
-# Reviewed-By: wrobel 2005-12-14
-
inherit eutils webapp depend.php depend.apache
DESCRIPTION="Web Based Management tool for Postfix for dealing with Postfix Style Virtual Domains
@@ -17,11 +13,11 @@ LICENSE="MPL-1.1"
KEYWORDS="~x86 ~amd64"
IUSE="mysql postgres"
-RDEPEND="virtual/httpd-php
- >=mail-mta/postfix-2.0.0
+RDEPEND=">=mail-mta/postfix-2.0.0
mysql? ( dev-perl/DBI dev-perl/DBD-mysql )
!www-apps/postfixadmin"
+need_php_httpd
need_apache
pkg_setup() {
@@ -42,23 +38,23 @@ src_unpack() {
cd "${S}"
# Remove .cvs* files and CVS directories
- find ${S} -name .cvs\* -or \( -type d -name CVS -prune \) -exec rm -rf {} \;
+ ecvs_clean
# Database support (we don't care wich one is used. Allow both of them!)
if use mysql; then
- cp ./DATABASE_MYSQL.TXT ${T}/mysql-setup.sql || die "Creating MySQL setup script failed!"
- cp ./TABLE_CHANGES.TXT ${T}/mysql-update.sql || die "Creating MySQL update script failed!"
- cp ./VIRTUAL_VACATION/INSTALL.TXT ${T}/VIRTUAL_VACATION_INSTALL.TXT
+ cp ./DATABASE_MYSQL.TXT "${T}"/mysql-setup.sql || die "Creating MySQL setup script failed!"
+ cp ./TABLE_CHANGES.TXT "${T}"/mysql-update.sql || die "Creating MySQL update script failed!"
+ cp ./VIRTUAL_VACATION/INSTALL.TXT "${T}"/VIRTUAL_VACATION_INSTALL.TXT
fi
if use postgres ; then
- cp ./DATABASE_PGSQL.TXT ${T}/pgsql-setup.sql || die "Creating PostgreSQL setup script failed!"
+ cp ./DATABASE_PGSQL.TXT "${T}"/pgsql-setup.sql || die "Creating PostgreSQL setup script failed!"
epatch "${FILESDIR}"/${P}-postgres-1.patch || die "Patching for postgres failed."
epatch "${FILESDIR}"/${P}-postgres-2.patch || die "Patching for postgres failed."
epatch "${FILESDIR}"/${P}-postgres-3.patch || die "Patching for postgres failed."
fi
# Rename config.inc.php
- cp ./config.inc.php.sample ${T}/config.inc.php || die "Creating config file failed!"
+ cp ./config.inc.php.sample "${T}"/config.inc.php || die "Creating config file failed!"
}
src_install() {
@@ -78,19 +74,19 @@ src_install() {
# these are things we need to add at a later date
#
if use mysql; then
- webapp_sqlscript mysql ${T}/mysql-setup.sql
- webapp_sqlscript mysql ${T}/mysql-update.sql 2.0.x
- webapp_sqlscript mysql ${T}/mysql-update.sql 1.5x
+ webapp_sqlscript mysql "${T}"/mysql-setup.sql
+ webapp_sqlscript mysql "${T}"/mysql-update.sql 2.0.x
+ webapp_sqlscript mysql "${T}"/mysql-update.sql 1.5x
fi
if use postgres ; then
- webapp_sqlscript pgsql ${T}/pgsql-setup.sql
+ webapp_sqlscript postgres "${T}"/pgsql-setup.sql
fi
einfo "Installing main files"
dodir ${MY_HTDOCSDIR}
cp -r . "${D}"${MY_HTDOCSDIR} || die "cp failed"
- cp ${T}/config.inc.php "${D}"${MY_HTDOCSDIR} || die "cp failed"
+ cp "${T}"/config.inc.php "${D}"${MY_HTDOCSDIR} || die "cp failed"
# handle documentation files
local docs="{BACKUP_MX,CHANGELOG,INSTALL,LANGUAGE,LICENSE.TXT,TABLE_BACKUP_MX,TABLE_CHANGES,UPGRADE}.TXT"