summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2021-05-27 09:29:15 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2021-05-27 09:29:36 +0000
commitcdf975f8ef1b2a775ddaa6812dcffc5383d2d08f (patch)
treeabf2dc796d7a4681a547343c8db261a5f7c2886a
parentwww-apps/drupal: Security bump - SA-CORE-2021-003. (diff)
downloadjmbsvicetto-cdf975f8ef1b2a775ddaa6812dcffc5383d2d08f.tar.gz
jmbsvicetto-cdf975f8ef1b2a775ddaa6812dcffc5383d2d08f.tar.bz2
jmbsvicetto-cdf975f8ef1b2a775ddaa6812dcffc5383d2d08f.zip
www-apps/drupal: Security bump - SA-CORE-2021-002.
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-7.80.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 48e8a74..f067e6c 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,4 +1,5 @@
DIST drupal-7.78.tar.gz 3335651 BLAKE2B 16bf438b4c7892f2d001d89e194e8735b66a0c2bdcae5f38c14bd1233122d437ad786142c82aa34c0e3e22ce9dc4b14903f1f58ea42447157615559cc02002f2 SHA512 405ed053c0b73e8768ee2a8dda9fb7257e8c8664cbf76025dd58d34ed16bfd0c9e853b92cfee03e85b38e9d6d9c578d52c6943e804224ce73cf7be414f4cfb91
+DIST drupal-7.80.tar.gz 3342293 BLAKE2B 342c8d69b3decdb50570590a96dd90f8fbfe5b403164e7ef3e855f7adb21e015bdebb6ecd943e23e4003f74c85ce889b4e4cf8e20eb65572337543120e15fb83 SHA512 38d3325252994abfa18709e52dac8194fb773185574019ee7b5037c1cee68ec5122afaf99e9c6dffef3053bbe7547f114783287aa9bcb51ee35f023cb7467c90
DIST drupal-8.9.13.tar.gz 19805034 BLAKE2B 2682c30b810ffd2089c51b0b9776b0b5fd664d415b4014d1923a1136683608a9231a6cda13732a28ea4cb7a277ffdb3e3427b6e49897a58645ac57c500d7e644 SHA512 2d8fa904a0c229c2430e24b89c85da9ec74ba88c12ed3b4afa9f2258377970ed8de7c0ce5397c89f2875e93b9f2e8d1bb174a71b4ad0904c1e6e2d7994c977c0
DIST drupal-8.9.16.tar.gz 19830094 BLAKE2B 90d9993832391817f2b6bda2943cc18f8231e4acfc76320353637ae84c07979e721ec5da85670e33e3fd56caf9e1a56182fcbfc4c3f6ed318b98cb7a7372c3af SHA512 633133cf13c27f51336c3280e4e76222b8abfcab3817925420a94846dece36434d800fee5aff68874a7e53170861a4e2dcda363e62f4bd9afd62ddd0ec0fe35b
DIST drupal-9.0.11.tar.gz 16877941 BLAKE2B 53969ee3ee1bd2ed3672e37e01cdbf181a895b20750087778b0bcd687e7b1ad5fb73d0bd280dbc324921294a0586cf966a1f781a5f1d47d3daa81c91aa17975e SHA512 98b20aba886e36f76a2bea9b6eba1e92bf81e57cc272460e510e24f4622a6895fdb37407cbfc07875ef4c04845a2255f794f8626646b17ed461342a5b04dce10
diff --git a/www-apps/drupal/drupal-7.80.ebuild b/www-apps/drupal/drupal-7.80.ebuild
new file mode 100644
index 0000000..4e6998d
--- /dev/null
+++ b/www-apps/drupal/drupal-7.80.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt INSTALL.sqlite.txt UPGRADE.txt "
+ dodoc ${docs}
+ rm -f ${docs} INSTALL COPYRIGHT.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+}