summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2016-05-09 00:49:04 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2016-05-09 00:49:04 +0000
commit3776e7e634aa7f93301e8744681ef21ee2d03d14 (patch)
tree1650989db4225c8109b00c07c669ae97e1560e83 /net-im
parentnet-im/nagibot Fix QA issues. Update YAML dependency. (diff)
downloadjmbsvicetto-3776e7e634aa7f93301e8744681ef21ee2d03d14.tar.gz
jmbsvicetto-3776e7e634aa7f93301e8744681ef21ee2d03d14.tar.bz2
jmbsvicetto-3776e7e634aa7f93301e8744681ef21ee2d03d14.zip
net-im/nagibot Bump to release 0.8.4.
Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/nagibot/Manifest1
-rw-r--r--net-im/nagibot/nagibot-0.8.4.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/net-im/nagibot/Manifest b/net-im/nagibot/Manifest
index 7fadbe9..91ecb9b 100644
--- a/net-im/nagibot/Manifest
+++ b/net-im/nagibot/Manifest
@@ -1 +1,2 @@
DIST Nagibot-v0.8.3.tar.gz 15781 SHA256 68c3b160cfc27a6e8e231fd7ddfc97f21cb0c5908451e10b6797dbc80befc813 SHA512 1e3eb004549f2f323e2c59f83c3ae5a8461bc38e90d51dbd9b878ccee1b56db49285485b532f9a5b17cef1b7105ec4879ce73761670444695da126f4032ea752 WHIRLPOOL 3694f23f57f16975baa924fa7a42ee9ee0032fba0133540e7681ffa75232f043ba12de186ec47c9df81a23344a06b337aede9dab6af73b2505634af616f10c78
+DIST Nagibot-v0.8.4.tar.gz 16320 SHA256 4f6dc7bdac252a6af9f88a4bea8eb9d521883691538672a9ccb0e90defee8705 SHA512 64a07093e935f5db33a16eebc66da1d263ceb405dea8840d963cfead5904dbc6f8544931a3d674367af1a5e17b0bea3bf018a7682532192f8e59d7c6d5c4bbc5 WHIRLPOOL 4d8b2c95ffcc20457e3cb6930b4b58b6caacb214383c451a0ee0d51f5fc6a463a4dca7d79f27f3d67f11275b8243d21af924cb98d3d50d6140628392c8efe261
diff --git a/net-im/nagibot/nagibot-0.8.4.ebuild b/net-im/nagibot/nagibot-0.8.4.ebuild
new file mode 100644
index 0000000..c88f418
--- /dev/null
+++ b/net-im/nagibot/nagibot-0.8.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="Nagibot"
+MY_PV="v${PV}"
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="Perl extension that uses XMPP for nagios notifications"
+HOMEPAGE="https://github.com/ajobs/NagiBot"
+SRC_URI="https://github.com/ajobs/${MY_PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/AnyEvent
+ dev-perl/AnyEvent-XMPP
+ dev-perl/File-Pid
+ dev-perl/Nagios-Status-HostStatus
+ dev-perl/Nagios-Status-ServiceStatus
+ dev-perl/Sys-CpuLoad
+ dev-perl/YAML
+ virtual/perl-Text-ParseWords
+ || (
+ net-analyzer/icinga
+ net-analyzer/nagios
+ )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-v${PV}"
+SRC_TEST="do"
+
+src_prepare() {
+ sed -i -e "s:!/opt/perl/bin/perl:!/usr/bin/perl:" nagibot.pl
+
+ cp "${FILESDIR}/nagibot.conf" "${S}"
+ cp "${FILESDIR}/nagibot.cfg" "${S}"
+ if ( use icinga ); then
+ sed -i -e "s:PREFIX=nagios:PREFIX=icinga:" nagibot.conf
+
+ sed -i -e "s:PREFIX:icinga:" nagibot.cfg
+ else
+ sed -i -e "s:PREFIX:nagios:" nagibot.cfg
+ fi
+}
+
+src_install() {
+ dobin nagibot.pl
+ newinitd "${FILESDIR}/nagibot.init" nagibot
+ newconfd "nagibot.conf" nagibot
+ dodir /etc/nagibot
+ insinto /etc/nagibot
+ doins nagibot.cfg
+
+ dodoc INSTALL README TODO Changes nagios-misccommands nagibot-example.conf
+}
+
+pkg_postinst() {
+ ewarn "Please check /etc/conf.d/nagibot.conf and /etc/nagibot/nagibot.cfg"
+ ewarn "as you need to set a few variables. Don't forget to set JID, configure"
+ ewarn "the rooms and the ids to notify and set the password for the JID."
+}