summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-21 23:25:12 +0200
committerMichał Górny <mgorny@gentoo.org>2013-07-21 23:25:12 +0200
commit891d5dd86714e1c314088bc4c5497483ff454b94 (patch)
tree724aa788e60675370476236d3cc503dcac4b0563 /dev-python
parentdev-python/pypy: Drop PyPy, the changes are being moved to the tree. (diff)
downloadmgorny-891d5dd86714e1c314088bc4c5497483ff454b94.tar.gz
mgorny-891d5dd86714e1c314088bc4c5497483ff454b94.tar.bz2
mgorny-891d5dd86714e1c314088bc4c5497483ff454b94.zip
dev-python/pypy-binpackage: Use explicit PYPY_BINPKG_STORE.
Package-Manager: portage-2.2.0_alpha188
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypy-binpackage/pypy-binpackage-2.0.2.ebuild26
1 files changed, 18 insertions, 8 deletions
diff --git a/dev-python/pypy-binpackage/pypy-binpackage-2.0.2.ebuild b/dev-python/pypy-binpackage/pypy-binpackage-2.0.2.ebuild
index 4dcdd19..4cb0ff8 100644
--- a/dev-python/pypy-binpackage/pypy-binpackage-2.0.2.ebuild
+++ b/dev-python/pypy-binpackage/pypy-binpackage-2.0.2.ebuild
@@ -33,6 +33,13 @@ DEPEND=">=sys-libs/zlib-1.1.3
S="${WORKDIR}/${MY_P}-src"
pkg_pretend() {
+ if [[ ! ${PYPY_BINPKG_STORE} ]]; then
+ eerror "Please set PYPY_BINPKG_STORE to the location where built"
+ eerror "packages are to be stored."
+
+ die "Set PYPY_BINPKG_STORE."
+ fi
+
CHECKREQS_MEMORY="2G"
use amd64 && CHECKREQS_MEMORY="4G"
check-reqs_pkg_pretend
@@ -47,12 +54,15 @@ pkg_setup() {
local cpu
if use amd64 || use amd64-linux; then
- cpu='athlon64'
+ cpu='x86-64'
+ elif use x86 || use x86-linux; then
+ # lowest with SSE2
+ cpu='pentium-m'
else
die "Unsupported arch ${ARCH}"
fi
- export CFLAGS="-march=${cpu} -O2 -pipe"
+ export CFLAGS="-march=${cpu} -mtune=generic -O2 -pipe"
export CXXFLAGS=${CFLAGS}
}
@@ -116,12 +126,12 @@ src_install() {
tar -cf "${BIN_P}${suffix}.tar" "${BIN_P}${suffix}" || die
xz -vz9 "${BIN_P}${suffix}.tar" || die
-
- insinto /tmp
- doins *.tar.xz
}
-pkg_postinst() {
- mkdir -p "${ROOT%/}"/home/mgorny/pypy-bin || die
- mv "${ROOT%/}"/tmp/${BIN_P}*.tar.xz "${ROOT%/}"/home/mgorny/pypy-bin || die
+# Yup, very hacky.
+pkg_preinst() {
+ # integrity check.
+ [[ ${PYPY_BINPKG_STORE} ]] || die 'PYPY_BINPKG_STORE unset, wtf?!'
+ mkdir -p "${ROOT%/}${PYPY_BINPKG_STORE}" || die
+ mv "${ROOT%/}"/tmp/${BIN_P}*.tar.xz "${ROOT%/}${PYPY_BINPKG_STORE}" || die
}