summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-02-08 19:03:35 +0100
committerUlrich Müller <ulm@gentoo.org>2021-02-08 19:03:35 +0100
commit0c29181b4e19f058de8982a913e31a14dd5e85ce (patch)
tree13b3a6aedb39ab639f6ac7f4c014c69901544de8
parentdev-util/ninka: Moved to gentoo repository. (diff)
downloadulm-0c29181b4e19f058de8982a913e31a14dd5e85ce.tar.gz
ulm-0c29181b4e19f058de8982a913e31a14dd5e85ce.tar.bz2
ulm-0c29181b4e19f058de8982a913e31a14dd5e85ce.zip
sys-auth/otpcalc: Live ebuild
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--sys-auth/otpcalc/metadata.xml11
-rw-r--r--sys-auth/otpcalc/otpcalc-9999.ebuild29
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-auth/otpcalc/metadata.xml b/sys-auth/otpcalc/metadata.xml
new file mode 100644
index 0000000..1135f79
--- /dev/null
+++ b/sys-auth/otpcalc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>ulm@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+ otpCalc is an RFC2289 and RFC1760 compliant one time password calculator,
+ written to use the GTK+ library for screen I/O.
+</longdescription>
+</pkgmetadata>
diff --git a/sys-auth/otpcalc/otpcalc-9999.ebuild b/sys-auth/otpcalc/otpcalc-9999.ebuild
new file mode 100644
index 0000000..940ec69
--- /dev/null
+++ b/sys-auth/otpcalc/otpcalc-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3 meson
+
+DESCRIPTION="A One Time Password and S/Key calculator for X"
+HOMEPAGE="http://www.killa.net/infosec/otpCalc/"
+EGIT_REPO_URI="https://gitlab.com/ulm/otpcalc.git"
+
+LICENSE="GPL-2+" # bundled crypto functions are not used
+SLOT="0"
+
+RDEPEND="dev-libs/openssl:0=
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local emesonargs=( -Dlibcrypto=enabled )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dosym otpCalc /usr/bin/otpcalc
+ newman - otpcalc.1 <<< ".so man1/otpCalc.1"
+}