summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-08-29 21:49:22 +0200
committerUlrich Müller <ulm@gentoo.org>2014-08-29 21:49:22 +0200
commit680ff84c16a975ba8ccd988200898a63c6bafbcb (patch)
treeffcc33bb4334ba0d3b5f1a2d55d96ebf1d0cac61
parentInitial import. Ebuild contributed by me. (diff)
downloadulm-680ff84c16a975ba8ccd988200898a63c6bafbcb.tar.gz
ulm-680ff84c16a975ba8ccd988200898a63c6bafbcb.tar.bz2
ulm-680ff84c16a975ba8ccd988200898a63c6bafbcb.zip
Copied from Portage tree.
Package-Manager: portage-2.2.12 RepoMan-Options: --force
-rw-r--r--net-misc/stunnel/ChangeLog10
-rw-r--r--net-misc/stunnel/Manifest1
-rw-r--r--net-misc/stunnel/files/stunnel-3.26-gentoo.diff29
-rw-r--r--net-misc/stunnel/metadata.xml14
-rw-r--r--net-misc/stunnel/stunnel-3.26.ebuild31
5 files changed, 85 insertions, 0 deletions
diff --git a/net-misc/stunnel/ChangeLog b/net-misc/stunnel/ChangeLog
new file mode 100644
index 0000000..719ac72
--- /dev/null
+++ b/net-misc/stunnel/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/stunnel
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*stunnel-3.26 (29 Aug 2014)
+
+ 29 Aug 2014; Ulrich Müller <ulm@gentoo.org> +stunnel-3.26.ebuild,
+ +files/stunnel-3.26-gentoo.diff, +metadata.xml:
+ Copied from Portage tree.
+
diff --git a/net-misc/stunnel/Manifest b/net-misc/stunnel/Manifest
new file mode 100644
index 0000000..f8c815b
--- /dev/null
+++ b/net-misc/stunnel/Manifest
@@ -0,0 +1 @@
+DIST stunnel-3.26.tar.gz 228923 SHA256 d2a55b089d46d14bc4b456bb1927303492dab6649867c67a005d2c9d1ededfb3 SHA512 5eb5abc7c74af00a36163ea43b1e8bd9072d4b5aa15c22d48f48252b1c9d0e2fd6ad8a9b7ce49bfa57ce88babb968ee17491bc64049f731f5e6a09675c75399a WHIRLPOOL dadc4fef2442a00e02952368f6245b11fcd53357ec3ce7a95e86e8c7f2a6ba2985bfce39e1c4f577b43254d68716319ce32a38fd3627d8f0f9539d6f1b515b05
diff --git a/net-misc/stunnel/files/stunnel-3.26-gentoo.diff b/net-misc/stunnel/files/stunnel-3.26-gentoo.diff
new file mode 100644
index 0000000..a6d0faa
--- /dev/null
+++ b/net-misc/stunnel/files/stunnel-3.26-gentoo.diff
@@ -0,0 +1,29 @@
+--- Makefile.in Sun Dec 23 12:03:25 2001
++++ Makefile.in Thu Jan 17 12:28:22 2002
+@@ -9,7 +9,7 @@
+ sbindir=@sbindir@
+ libdir=@libdir@
+ man8dir=@mandir@/man8
+-piddir=@localstatedir@/stunnel/
++piddir=/var/run
+ ssldir=@ssldir@
+ openssl=$(ssldir)/bin/openssl
+ PEM_DIR=@PEM_DIR@
+@@ -24,7 +24,7 @@
+ LIBS=@LIBS@
+ HEADERS=common.h prototypes.h client.h
+ OBJS=client.o stunnel.o ssl.o protocol.o sthreads.o pty.o log.o options.o
+-DESTFILES=$(sbindir)/stunnel $(libdir)/stunnel.so $(man8dir)/stunnel.8 $(PEM_DIR)/stunnel.pem
++DESTFILES=$(sbindir)/stunnel $(libdir)/stunnel.so $(man8dir)/stunnel.8
+
+ WINGCC=i386-mingw32msvc-gcc
+ WINCFLAGS=-O2 -Wall -DUSE_WIN32=1 -DHAVE_OPENSSL=1 -DFD_SETSIZE=4096 -DVERSION=\"@VERSION@\" -I../openssl-0.9.6b/outinc
+@@ -33,7 +33,7 @@
+
+ # standard external rules
+
+-all: stunnel stunnel.8 stunnel.html stunnel.so stunnel.pem
++all: stunnel stunnel.8 stunnel.html stunnel.so
+
+ install: all installdirs $(DESTFILES)
+
diff --git a/net-misc/stunnel/metadata.xml b/net-misc/stunnel/metadata.xml
new file mode 100644
index 0000000..b8050b9
--- /dev/null
+++ b/net-misc/stunnel/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>ulm@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+ Stunnel is a program that allows you to encrypt arbitrary TCP
+ connections inside SSL (Secure Sockets Layer) available on both Unix
+ and Windows. Stunnel can allow you to secure non-SSL aware daemons
+ and protocols (like POP, IMAP, LDAP, etc) by having Stunnel provide
+ the encryption, requiring no changes to the daemon's code.
+</longdescription>
+</pkgmetadata>
diff --git a/net-misc/stunnel/stunnel-3.26.ebuild b/net-misc/stunnel/stunnel-3.26.ebuild
new file mode 100644
index 0000000..4793d65
--- /dev/null
+++ b/net-misc/stunnel/stunnel-3.26.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-3.26.ebuild,v 1.23 2013/08/02 15:17:48 ulm Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="TLS/SSL - Port Wrapper"
+HOMEPAGE="http://www.stunnel.org/"
+SRC_URI="http://www.stunnel.org/download/stunnel/src/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86"
+IUSE="selinux"
+
+DEPEND=">=dev-libs/openssl-0.9.6j"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-stunnel )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.diff
+}
+
+src_install() {
+ dosbin stunnel
+ dolib.so stunnel.so
+ dodoc FAQ README HISTORY BUGS PORTS TODO
+ doman stunnel.8
+}