summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/fortune-mod-theo-de-raadt/fortune-mod-theo-de-raadt-20140220.ebuild')
-rw-r--r--games-misc/fortune-mod-theo-de-raadt/fortune-mod-theo-de-raadt-20140220.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-misc/fortune-mod-theo-de-raadt/fortune-mod-theo-de-raadt-20140220.ebuild b/games-misc/fortune-mod-theo-de-raadt/fortune-mod-theo-de-raadt-20140220.ebuild
new file mode 100644
index 0000000..74f435d
--- /dev/null
+++ b/games-misc/fortune-mod-theo-de-raadt/fortune-mod-theo-de-raadt-20140220.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Quotes from OpenBSD founder Theo de Raadt"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/src/usr.bin/mg/theo.c"
+# split off from app-editors/mg
+SRC_URI="http://homepage.boetes.org/software/mg/mg-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="games-misc/fortune-mod"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/mg-${PV}"
+
+src_configure() { :; }
+
+src_compile() {
+ sed -e '1,/talk.*{/d;/^}/,$d;s/^[ \t]*"\(.*\)",\?[ \t]*$/\1\n%/' \
+ theo.c | fold -s -w 70 >theo-de-raadt || die
+ strfile theo-de-raadt || die
+}
+
+src_install() {
+ insinto /usr/share/fortune
+ doins theo-de-raadt{,.dat}
+}