summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-25 21:30:12 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-25 21:43:07 +0100
commit003d5dbd50befe69189ec1bce24f822ea8fcb75d (patch)
tree6777f4baf36ac9d8aba5436e41a7c20ca2683f33
parentdev-python/python-utils: Bump to 2.5.3 (diff)
downloadgentoo-003d5dbd50befe69189ec1bce24f822ea8fcb75d.tar.gz
gentoo-003d5dbd50befe69189ec1bce24f822ea8fcb75d.tar.bz2
gentoo-003d5dbd50befe69189ec1bce24f822ea8fcb75d.zip
dev-python/zope-schema: Bump to 6.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/zope-schema/Manifest1
-rw-r--r--dev-python/zope-schema/zope-schema-6.0.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/zope-schema/Manifest b/dev-python/zope-schema/Manifest
index 171d703a8e5d..be25e444d9cf 100644
--- a/dev-python/zope-schema/Manifest
+++ b/dev-python/zope-schema/Manifest
@@ -1 +1,2 @@
DIST zope.schema-6.0.0.tar.gz 110343 BLAKE2B 8dad6fcbd5bf3ef5902657bb7cfc4d31509cf8b74be3e44ec2a5977dc998bbe9b2605dd0edd85aec7f5e67e5e4e7ea6e9ddde2e63f5d56226dfead804e10eb61 SHA512 3258e6b2bf97485b9496f19319ef5af9a1e908b6c2661c27f45cfd64057597cfd514acbe79d86ddda1b80e66be45a10680fc3d9e662513b360d5f047917735d8
+DIST zope.schema-6.0.1.tar.gz 108325 BLAKE2B 4e23b2a864ce8ca650d71723f2ec89f04e05e7739cbe6b236ebdd4ffe80261a75faac414ae411b1ea525f93375f8eb4b6eb1e6186e04d225467b729f5c630b77 SHA512 c8b9182975b1f2834827877c725a8d0c800bf3cbed9dce2625bb3e1715c0fb7d346b8206f47a96994fa79240a0cb30c4aa38cea56f9ecb79351fd97e0bc021ba
diff --git a/dev-python/zope-schema/zope-schema-6.0.1.ebuild b/dev-python/zope-schema/zope-schema-6.0.1.ebuild
new file mode 100644
index 000000000000..f137c80de517
--- /dev/null
+++ b/dev-python/zope-schema/zope-schema-6.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope schema Architecture"
+HOMEPAGE="https://github.com/zopefoundation/zope.schema http://docs.zope.org/zope.schema/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-5.0.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/zope-i18nmessageid[${PYTHON_USEDEP}]
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ dev-python/zope-testrunner[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # remove .pth files since dev-python/namespace-zope handles the ns
+ find "${D}" -name '*.pth' -delete || die
+}