summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-19 03:11:46 +0100
committerSam James <sam@gentoo.org>2022-10-19 03:11:46 +0100
commit0065c8d2fb3b3838fd8940725cd84fb15506ac43 (patch)
tree64ebfdb2ad50986ba6065719901179a5e917ac7d
parentnet-analyzer/bing: add 1.3.5 (diff)
downloadgentoo-0065c8d2fb3b3838fd8940725cd84fb15506ac43.tar.gz
gentoo-0065c8d2fb3b3838fd8940725cd84fb15506ac43.tar.bz2
gentoo-0065c8d2fb3b3838fd8940725cd84fb15506ac43.zip
app-arch/createrepo_c: add 0.20.1
Closes: https://bugs.gentoo.org/875698 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-arch/createrepo_c/Manifest1
-rw-r--r--app-arch/createrepo_c/createrepo_c-0.20.1.ebuild42
-rw-r--r--app-arch/createrepo_c/files/createrepo_c-0.20.1-Include-rpm-rpmstring.h-for-rasprintf.patch20
3 files changed, 63 insertions, 0 deletions
diff --git a/app-arch/createrepo_c/Manifest b/app-arch/createrepo_c/Manifest
index 3207cc02e8ba..ad7a2616f3a4 100644
--- a/app-arch/createrepo_c/Manifest
+++ b/app-arch/createrepo_c/Manifest
@@ -1 +1,2 @@
DIST createrepo_c-0.16.2.tar.gz 601935 BLAKE2B 8b9f279d97744e9eeb68cfcc7e9a229ab5a4d8cfca74a2a3d444915eaae7a6d2fa113e517fdcd72b69d0343e541ccce8020f50162e4800c54ba989cea8d5756e SHA512 c63abc8aa6c65584b51a0aa337e261fe5d9a52d72287874f86531caa8133718290a4f44aa765979fa319973c4ba0681437a26f84f64bd5bf781c86a6daa8a39b
+DIST createrepo_c-0.20.1.tar.gz 614968 BLAKE2B 8eb35c121e1beaa960310d10bfe616799b3a6b13d99f1e8c9d4077975cc929c9f786dec7d26a17d7efbd1859e2e7d8a614147c36a0a82c87f1c1c1a652afa6f3 SHA512 54a2cc7c7cd3f3b9a0c23cd8c136ae1331e7fa7cc995189088e7e6f2276c78b2b84e21c2a2b93f4528b5e9e4018dd6525262c8aaba3bc8a1412a51dfafd101f7
diff --git a/app-arch/createrepo_c/createrepo_c-0.20.1.ebuild b/app-arch/createrepo_c/createrepo_c-0.20.1.ebuild
new file mode 100644
index 000000000000..91a1e6965990
--- /dev/null
+++ b/app-arch/createrepo_c/createrepo_c-0.20.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C implementation of createrepo"
+HOMEPAGE="https://github.com/rpm-software-management/createrepo_c"
+SRC_URI="https://github.com/rpm-software-management/createrepo_c/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Notes: Help with enabling the python support would be great
+
+DEPEND="app-arch/bzip2:=
+ app-arch/rpm
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl:=
+ net-misc/curl
+ sys-apps/file
+ sys-libs/zlib:="
+RDEPEND="${DEPEND}
+ app-arch/lzma"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.20.1-Include-rpm-rpmstring.h-for-rasprintf.patch
+)
+
+src_configure() {
+ # Other than for python (where tests are failing) we have special no-in-tree dependencies.
+ local mycmakeargs=(
+ -DENABLE_DRPM=OFF
+ -DENABLE_PYTHON=OFF
+ -DWITH_ZCHUNK=OFF
+ -DWITH_LIBMODULEMD=OFF
+ )
+ cmake_src_configure
+}
diff --git a/app-arch/createrepo_c/files/createrepo_c-0.20.1-Include-rpm-rpmstring.h-for-rasprintf.patch b/app-arch/createrepo_c/files/createrepo_c-0.20.1-Include-rpm-rpmstring.h-for-rasprintf.patch
new file mode 100644
index 000000000000..f7df38935aed
--- /dev/null
+++ b/app-arch/createrepo_c/files/createrepo_c-0.20.1-Include-rpm-rpmstring.h-for-rasprintf.patch
@@ -0,0 +1,20 @@
+https://github.com/rpm-software-management/createrepo_c/pull/328
+
+From cddd4c161523cf4340aa59f832d130e7c34ffd14 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Wed, 19 Oct 2022 03:10:06 +0100
+Subject: [PATCH] Include <rpm/rpmstring.h> for rasprintf
+
+Fixes build with Clang 16.
+
+Bug: https://bugs.gentoo.org/875698
+--- a/src/xml_file.c
++++ b/src/xml_file.c
+@@ -20,6 +20,7 @@
+ #include <glib.h>
+ #include <glib/gstdio.h>
+ #include <assert.h>
++#include <rpm/rpmstring.h>
+ #include "xml_file.h"
+ #include <errno.h>
+ #include "error.h"