summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-23 08:30:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-23 09:19:13 +0200
commit03a1503c8f2c5c6a6cd9e4398a1c11b04280cf54 (patch)
treece6e2d31b742e98c546c626f231e768a12c64e24
parentdev-python/pycryptodome: Bump to 3.15.0 (diff)
downloadgentoo-03a1503c8f2c5c6a6cd9e4398a1c11b04280cf54.tar.gz
gentoo-03a1503c8f2c5c6a6cd9e4398a1c11b04280cf54.tar.bz2
gentoo-03a1503c8f2c5c6a6cd9e4398a1c11b04280cf54.zip
dev-python/ipywidgets: Bump to 7.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ipywidgets/Manifest1
-rw-r--r--dev-python/ipywidgets/ipywidgets-7.7.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/Manifest b/dev-python/ipywidgets/Manifest
index 832122d805b3..33cdcdce151f 100644
--- a/dev-python/ipywidgets/Manifest
+++ b/dev-python/ipywidgets/Manifest
@@ -1 +1,2 @@
DIST ipywidgets-7.7.0.tar.gz 4074763 BLAKE2B cff338dd635c57943161c78708e6a69abccaa46878e0bedb11ead76590b858ba57ce4dcfa8052533a4849da0dc9d5472987a7918fd2043462a21a908105d7910 SHA512 038da040912e6701762fb66fb3b6996ce0a59706afb05405b5932c02d34733842b227426f0b29eea115196bab384617425b0553c5db13a9dc832bddef63dfb92
+DIST ipywidgets-7.7.1.tar.gz 4075672 BLAKE2B 1e52d3b3b9380f42f67ad658f6e8579a61220e7160c10b1569437c1fd74ce962fbe746f3a6a3e302b5417812f69807deddc0ae3fe255b8e2f213d65103d55362 SHA512 ed6bf1a59a511714a3af96cc66e7665b9b264f56862ca4ea02d943137fcc6018da8fcb8dff4a8f9157bfb46cc19b7d58ceaff028e84f2f8d18ee16e57ce7fb96
diff --git a/dev-python/ipywidgets/ipywidgets-7.7.1.ebuild b/dev-python/ipywidgets/ipywidgets-7.7.1.ebuild
new file mode 100644
index 000000000000..8f080eed2ecd
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-7.7.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="
+ https://ipywidgets.readthedocs.io/
+ https://github.com/jupyter-widgets/ipywidgets/
+ https://pypi.org/project/ipywidgets/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/ipython_genutils-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-3.6.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # upstream hack to autoconfigure ipywidgets in jupyter
+ # we don't have jupyterlab_widgets packaged
+ sed -i -e '/jupyterlab_widgets/d' setup.py || die
+ distutils-r1_src_prepare
+}