summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-22 20:35:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-22 22:00:52 +0200
commit03bcb1c9d44539cdc02d545db26e2d65ad301a17 (patch)
treed402a87badc223cb357127485d5ef10715403866
parentdev-python/scikit-build-core: Bump to 0.5.0 (diff)
downloadgentoo-03bcb1c9d44539cdc02d545db26e2d65ad301a17.tar.gz
gentoo-03bcb1c9d44539cdc02d545db26e2d65ad301a17.tar.bz2
gentoo-03bcb1c9d44539cdc02d545db26e2d65ad301a17.zip
dev-python/pymongo: Bump to 4.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pymongo/Manifest1
-rw-r--r--dev-python/pymongo/metadata.xml9
-rw-r--r--dev-python/pymongo/pymongo-4.5.0.ebuild152
3 files changed, 159 insertions, 3 deletions
diff --git a/dev-python/pymongo/Manifest b/dev-python/pymongo/Manifest
index 9b007d9eae42..be835a0daa2c 100644
--- a/dev-python/pymongo/Manifest
+++ b/dev-python/pymongo/Manifest
@@ -1 +1,2 @@
DIST mongo-python-driver-4.4.1.gh.tar.gz 1461820 BLAKE2B 42b2f5663bbc632205ebc1e979c6434122d797043cc545b3ff5b02956acd4d8d2b3a6b4a0308ca041fbb82aa3f530b305f4d21d42954c15b0c3ace3da6e1efd8 SHA512 fbdc6bd60eefbd554cadbea2173340e89e3cbec3377c97a592789750bb86ec68818d40f43b020c68023ff6c415bb4ceb36e7fb169d72b3e9c218880c6bfaf339
+DIST mongo-python-driver-4.5.0.gh.tar.gz 1481970 BLAKE2B fcb019042b6447093e1cfb9d66514954c31a26322060842b3c8e93d865f74db356004c6d7090d1a535d1ce523513cbd9e7935c7ee7655cdd47691d1b7ede97f0 SHA512 eb607f692c28daacef436e7649b3265465f8f785a68b29eda16b5ab5d926d0fa4737bcc6974f54778794dfd7fbcd95c30478867d6479ea45d412f2404cb2aa30
diff --git a/dev-python/pymongo/metadata.xml b/dev-python/pymongo/metadata.xml
index 49d5ee837cb8..dee6e50c5e66 100644
--- a/dev-python/pymongo/metadata.xml
+++ b/dev-python/pymongo/metadata.xml
@@ -9,10 +9,13 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
- <longdescription lang="en">PyMongo is a Python distribution containing tools
- for working with MongoDB, and is the recommended way to work
- with MongoDB from Python.</longdescription>
+ <longdescription lang="en">
+ PyMongo is a Python distribution containing tools for working
+ with MongoDB, and is the recommended way to work with MongoDB
+ from Python.
+ </longdescription>
<use>
+ <flag name="native-extensions">Compiles native C extensions</flag>
<flag name="test-full">
Run test suite in full, including tests that run a local
database instance.
diff --git a/dev-python/pymongo/pymongo-4.5.0.ebuild b/dev-python/pymongo/pymongo-4.5.0.ebuild
new file mode 100644
index 000000000000..0a82c759cf48
--- /dev/null
+++ b/dev-python/pymongo/pymongo-4.5.0.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit check-reqs distutils-r1
+
+MY_P=mongo-python-driver-${PV}
+DESCRIPTION="Python driver for MongoDB"
+HOMEPAGE="
+ https://github.com/mongodb/mongo-python-driver/
+ https://pypi.org/project/pymongo/
+"
+SRC_URI="
+ https://github.com/mongodb/mongo-python-driver/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="doc kerberos +native-extensions +test-full"
+
+RDEPEND="
+ <dev-python/dnspython-3.0.0[${PYTHON_USEDEP}]
+ kerberos? ( dev-python/kerberos[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ test-full? (
+ >=dev-db/mongodb-2.6.0
+ )
+ )
+"
+
+distutils_enable_sphinx doc
+distutils_enable_tests unittest
+
+reqcheck() {
+ if use test && use test-full; then
+ # During the tests, database size reaches 1.5G.
+ local CHECKREQS_DISK_BUILD=1536M
+
+ check-reqs_${1}
+ fi
+}
+
+pkg_pretend() {
+ reqcheck pkg_pretend
+}
+
+pkg_setup() {
+ reqcheck pkg_setup
+}
+
+python_compile() {
+ # causes build errors to be fatal
+ local -x TOX_ENV_NAME=whatever
+ local DISTUTILS_ARGS=()
+ # unconditionally implicitly disabled on pypy3
+ if ! use native-extensions; then
+ DISTUTILS_ARGS+=( --no_ext )
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ rm -rf bson pymongo || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_DESELECT=(
+ # network-sandbox
+ test/test_client.py::ClientUnitTest::test_connection_timeout_ms_propagates_to_DNS_resolver
+ test/test_client.py::TestClient::test_service_name_from_kwargs
+ test/test_client.py::TestClient::test_srv_max_hosts_kwarg
+ test/test_dns.py::TestCaseInsensitive::test_connect_case_insensitive
+ test/test_srv_polling.py
+ test/test_uri_spec.py::TestAllScenarios::test_test_uri_options_srv-options_SRV_URI_with_custom_srvServiceName
+ test/test_uri_spec.py::TestAllScenarios::test_test_uri_options_srv-options_SRV_URI_with_invalid_type_for_srvMaxHosts
+ test/test_uri_spec.py::TestAllScenarios::test_test_uri_options_srv-options_SRV_URI_with_negative_integer_for_srvMaxHosts
+ test/test_uri_spec.py::TestAllScenarios::test_test_uri_options_srv-options_SRV_URI_with_positive_srvMaxHosts_and_loadBalanced=fa
+ test/test_uri_spec.py::TestAllScenarios::test_test_uri_options_srv-options_SRV_URI_with_srvMaxHosts
+ test/test_uri_spec.py::TestAllScenarios::test_test_uri_options_srv-options_SRV_URI_with_srvMaxHosts=0_and_loadBalanced=true
+ test/test_uri_spec.py::TestAllScenarios::test_test_uri_options_srv-options_SRV_URI_with_srvMaxHosts=0_and_replicaSet
+
+ # broken regularly by changes in mypy
+ test/test_typing.py::TestMypyFails::test_mypy_failures
+ )
+
+ if ! use test-full; then
+ # .invalid is guaranteed to return NXDOMAIN per RFC 6761
+ local -x DB_IP=mongodb.invalid
+ epytest
+ return
+ fi
+
+ # Yes, we need TCP/IP for that...
+ local -x DB_IP=127.0.0.1
+ local -x DB_PORT=27000
+
+ local dbpath=${TMPDIR}/mongo.db
+ local logpath=${TMPDIR}/mongod.log
+
+ # Now, the hard part: we need to find a free port for mongod.
+ # We're just trying to run it random port numbers and check the log
+ # for bind errors. It shall be noted that 'mongod --fork' does not
+ # return failure when it fails to bind.
+
+ mkdir -p "${dbpath}" || die
+ while true; do
+ ebegin "Trying to start mongod on port ${DB_PORT}"
+
+ LC_ALL=C \
+ mongod --dbpath "${dbpath}" --nojournal \
+ --bind_ip ${DB_IP} --port ${DB_PORT} \
+ --unixSocketPrefix "${TMPDIR}" \
+ --logpath "${logpath}" --fork \
+ && sleep 2
+
+ # Now we need to check if the server actually started...
+ if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
+ # yay!
+ eend 0
+ break
+ elif grep -q 'Address already in use' "${logpath}"; then
+ # ay, someone took our port!
+ eend 1
+ : $(( DB_PORT += 1 ))
+ continue
+ else
+ eend 1
+ eerror "Unable to start mongod for tests. See the server log:"
+ eerror " ${logpath}"
+ die "Unable to start mongod for tests."
+ fi
+ done
+
+ local failed
+ nonfatal epytest || failed=1
+
+ mongod --dbpath "${dbpath}" --shutdown || die
+
+ [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
+
+ rm -rf "${dbpath}" || die
+}