summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-12-17 19:06:52 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-12-17 20:00:16 +0200
commit0700968c65cbe02365701a0cf7c9b5d6e5d13f70 (patch)
tree78832ee9d37534d5edf7b01db6d90ba0c5f88d34
parentvirtual/perl-Module-CoreList: Stabilize 5.202.311.290 arm, #920096 (diff)
downloadgentoo-0700968c65cbe02365701a0cf7c9b5d6e5d13f70.tar.gz
gentoo-0700968c65cbe02365701a0cf7c9b5d6e5d13f70.tar.bz2
gentoo-0700968c65cbe02365701a0cf7c9b5d6e5d13f70.zip
dev-python/hiredis: add 2.3.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/hiredis/Manifest1
-rw-r--r--dev-python/hiredis/hiredis-2.3.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/hiredis/Manifest b/dev-python/hiredis/Manifest
index 247154493dad..c30088fd18a5 100644
--- a/dev-python/hiredis/Manifest
+++ b/dev-python/hiredis/Manifest
@@ -1 +1,2 @@
DIST hiredis-py-2.3.0.gh.tar.gz 18179 BLAKE2B d87460d3ea75f81f9017a837f44281e7733104e5772ed53dc9471eb18a38b0a9e1298ddb3c78b8d3c5ab7a8e1f71e966bbaa10e06969321e7940b8965ac56b2f SHA512 4e72f71719e9616913e5ed6dc9d2e01ad91d44715231c1eda1a1c6570d75c00be634093712444fc9a86bc6843278ab34c33c7362ffd5b8171f4ff775aaf0c4bd
+DIST hiredis-py-2.3.2.gh.tar.gz 19076 BLAKE2B 4a3e747765f559407b3ad84524bc1040e3a530723b5756320743fc20400bc70e867d48e71696d732a5fa5eb231199cbefb6f487d0b5ece6fc8f6c41f10f3c0d8 SHA512 1a22ab324f9675973c3dc37c55d6dd9cf43fbc161003003a73b2e1dfbb3fed7dcb1433f4fc51045a88cb2735f7c8495b93a819a0a9f6300e05b0cc85160eaace
diff --git a/dev-python/hiredis/hiredis-2.3.2.ebuild b/dev-python/hiredis/hiredis-2.3.2.ebuild
new file mode 100644
index 000000000000..f84862162b67
--- /dev/null
+++ b/dev-python/hiredis/hiredis-2.3.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+MY_P=hiredis-py-${PV}
+DESCRIPTION="Python extension that wraps hiredis"
+HOMEPAGE="
+ https://github.com/redis/hiredis-py/
+ https://pypi.org/project/hiredis/
+"
+SRC_URI="
+ https://github.com/redis/hiredis-py/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/hiredis-1.0.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/hiredis-2.2.2-system-libs.patch
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ rm -rf hiredis || die
+ epytest
+}