summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2022-11-22 13:58:25 -0800
committerJason Zaman <perfinion@gentoo.org>2022-11-25 10:22:01 -0800
commit103c963ca6967f41134f66269f53d94169e9fd3c (patch)
treef784d5db2f96290cb99cb7ccbba2462787cfd943
parentdev-lua/luacheck: add 1.0.0 (diff)
downloadgentoo-103c963ca6967f41134f66269f53d94169e9fd3c.tar.gz
gentoo-103c963ca6967f41134f66269f53d94169e9fd3c.tar.bz2
gentoo-103c963ca6967f41134f66269f53d94169e9fd3c.zip
sci-visualization/tensorboard: add 2.11.0
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
-rw-r--r--sci-visualization/tensorboard/Manifest1
-rw-r--r--sci-visualization/tensorboard/tensorboard-2.11.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/sci-visualization/tensorboard/Manifest b/sci-visualization/tensorboard/Manifest
index 472537c49964..5562b5598f8d 100644
--- a/sci-visualization/tensorboard/Manifest
+++ b/sci-visualization/tensorboard/Manifest
@@ -1 +1,2 @@
DIST tensorboard-2.10.0.zip 5873469 BLAKE2B b03a804682275abd83482e6dc8e62bef4301d796ef5bd2b02bed8d15ab16ff4bd19f1b9e3488e12ea6c03e1b7a85fd69a6a226f0a5378da2067c661b7f1f2f7e SHA512 04da20089d7e24e2c519da24bb8ad32f622386799e28403e036d40c29bc99011cc374480176776b0801df0e37eb2b0e93a987d2a97cd7406eabb75bfd649a311
+DIST tensorboard-2.11.0.zip 5990351 BLAKE2B d6796fceb047abc69c84c8f30ce6b5e0739a376e110fb7e2bb78ee5b6c7dd8d1344546950d46dbdc3a47780f4ad685be186087286225dbeb9ebce558f0837d8c SHA512 f1b908e13a56a86f6618ae8bf596339243642d0f00793d326ac884fd8e736bb316331728b474022936570fb6202b323d8ba2bf4908619aa1f79411b904edf209
diff --git a/sci-visualization/tensorboard/tensorboard-2.11.0.ebuild b/sci-visualization/tensorboard/tensorboard-2.11.0.ebuild
new file mode 100644
index 000000000000..f9f4786e1e1e
--- /dev/null
+++ b/sci-visualization/tensorboard/tensorboard-2.11.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit python-r1
+
+DESCRIPTION="TensorFlow's Visualization Toolkit"
+HOMEPAGE="https://www.tensorflow.org/"
+SRC_URI="https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/bleach[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.6.3[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-oauthlib-0.4.1[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-41[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.4.1[${PYTHON_USEDEP}]"
+BDEPEND="app-arch/unzip
+ ${PYTHON_DEPS}"
+PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ eapply_user
+
+ sed -i -e '/_vendor.__init__/d' -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' -e '/_vendor.webencodings/d' \
+ "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
+ grep -q "_vendor" "${S}/${P}.dist-info/RECORD" && die "More vendored deps found"
+
+ find "${S}/${PN}" -name '*.py' -exec sed -i \
+ -e 's/^from tensorboard\._vendor import /import /' \
+ -e 's/^from tensorboard\._vendor\./from /' \
+ {} + || die "failed to unvendor"
+
+ rm -rf "${S}/${PN}/_vendor" || die
+
+ sed -i -e '/tensorboard-plugin-/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove plugin deps"
+ sed -i -e '/tensorboard-data-server/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove data-server deps"
+ sed -i -e 's/google-auth-oauthlib.*$/google-auth-oauthlib/' "${S}/${P}.dist-info/METADATA" \
+ || die "failed to relax oauth deps"
+ sed -i -e 's/protobuf.*$/protobuf/' "${S}/${P}.dist-info/METADATA" \
+ || die "failed to relax protobuf deps"
+}
+
+src_install() {
+ do_install() {
+ python_domodule "${PN}"
+ python_domodule "${P}.dist-info"
+ }
+ python_foreach_impl do_install
+}