summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-01-22 17:17:56 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-01-22 17:18:12 +0100
commit12ab46c609527fedc98c8830a45307d4eaccd62c (patch)
tree3001bd4a147307d8c340da270b44e397bbf973f5
parentapp-crypt/certbot-nginx: Initial version (diff)
downloadgentoo-12ab46c609527fedc98c8830a45307d4eaccd62c.tar.gz
gentoo-12ab46c609527fedc98c8830a45307d4eaccd62c.tar.bz2
gentoo-12ab46c609527fedc98c8830a45307d4eaccd62c.zip
app-crypt/certbot-nginx: Version bump to 0.10.1
Package-Manager: portage-2.3.3
-rw-r--r--app-crypt/certbot-nginx/Manifest1
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-0.10.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
new file mode 100644
index 000000000000..1da344087f16
--- /dev/null
+++ b/app-crypt/certbot-nginx/Manifest
@@ -0,0 +1 @@
+DIST certbot-nginx-0.10.1.tar.gz 823669 SHA256 c91b5fddb50dfd46545c12c1e96d1bb5e2794652c11421a6f5d9dad2bbca4d52 SHA512 4e45280b9cb6db3f8dcecfbf0cf64c990ea58d8607ed1aea9853c7248f8830301cc8685126eeb0d0c2ef0e23298c9070b291110d733e72867967bc9506900702 WHIRLPOOL ae08a9236adf69915c4a141106aa104563b1298f9fd3a32491ed8c45fddc9f32243154ba5bde9af7a8b74a95a1d2b7d337e4cbcc37f35ba997a7a50eb2f15200
diff --git a/app-crypt/certbot-nginx/certbot-nginx-0.10.1.ebuild b/app-crypt/certbot-nginx/certbot-nginx-0.10.1.ebuild
new file mode 100644
index 000000000000..babe1c82fd63
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-0.10.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-ngin}-${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+CDEPEND=">=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ ~app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"