summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-15 03:23:10 +0100
committerSam James <sam@gentoo.org>2024-07-15 03:23:10 +0100
commit1ecbeb52c4d3d633881f917e08ce7dbe2c906958 (patch)
tree0e42f89495eb1ac710341b6370df14e6c56c64f9
parentsys-libs/minizip-ng: add 4.0.7 (diff)
downloadgentoo-1ecbeb52c4d3d633881f917e08ce7dbe2c906958.tar.gz
gentoo-1ecbeb52c4d3d633881f917e08ce7dbe2c906958.tar.bz2
gentoo-1ecbeb52c4d3d633881f917e08ce7dbe2c906958.zip
sys-libs/zlib-ng: add 2.1.7
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-libs/zlib-ng/Manifest1
-rw-r--r--sys-libs/zlib-ng/zlib-ng-2.1.7.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/sys-libs/zlib-ng/Manifest b/sys-libs/zlib-ng/Manifest
index 7b64ea0bc919..975620da5039 100644
--- a/sys-libs/zlib-ng/Manifest
+++ b/sys-libs/zlib-ng/Manifest
@@ -1 +1,2 @@
DIST zlib-ng-2.1.6.tar.gz 2412106 BLAKE2B 9ca16c19c2c799e68e099d44721b27dc33ad9e859a3d6572bebe3a75c618bffd78e19f0d4c0607802d1c8fa6a8f328d62f9993648a99c1d2e0e5fdcaf87a2667 SHA512 59ef586c09b9a63788475abfd6dd59ed602316b38f543f801bea802ff8bec8b55a89bee90375b8bbffa3bdebc7d92a00903f4b7c94cdc1a53a36e2e1fd71d13a
+DIST zlib-ng-2.1.7.tar.gz 2406554 BLAKE2B c92a2ad481e4a10b8ec164f3974a09242118e2c16dbe51553b7f6e5c33886997dc390e73ce26f99bdb5ce0ecae3eb19322059576a83da1c3958435554773878c SHA512 03e6d22ecb39c9425fa2977e5db608f765387a06b9ef93b162e403bb155aa3b59bbaedb41e827e7e159d6635325d804dcd4314a25adcb35b83e6e0cf1153aabe
diff --git a/sys-libs/zlib-ng/zlib-ng-2.1.7.ebuild b/sys-libs/zlib-ng/zlib-ng-2.1.7.ebuild
new file mode 100644
index 000000000000..d9bf5f443d25
--- /dev/null
+++ b/sys-libs/zlib-ng/zlib-ng-2.1.7.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Worth keeping an eye on 'develop' branch upstream for possible backports,
+# as they copied this practice from sys-libs/zlib upstream.
+
+inherit cmake-multilib
+
+DESCRIPTION="Fork of the zlib data compression library"
+HOMEPAGE="https://github.com/zlib-ng/zlib-ng"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+
+CPU_USE=(
+ x86_{avx2,avx512f,avx512_vnni,sse2,ssse3,sse4_2,pclmul,vpclmulqdq}
+ arm_{crc32,neon}
+ ppc_{altivec,vsx2,vsx3}
+)
+IUSE="compat ${CPU_USE[@]/#/cpu_flags_} test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-cpp/gtest )
+"
+RDEPEND="
+ compat? ( !sys-libs/zlib )
+"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DZLIB_COMPAT=$(usex compat)
+ -DZLIB_ENABLE_TESTS=$(usex test)
+ -DWITH_GTEST=$(usex test)
+
+ # Unaligned access is controversial and undefined behaviour
+ # Let's keep it off for now
+ # https://github.com/gentoo/gentoo/pull/17167
+ -DWITH_UNALIGNED=OFF
+ )
+
+ # The intrinsics options are all defined conditionally, so we need
+ # to enable them on/off per-arch here for now.
+ # TODO: There's no s390x USE_EXPAND yet
+ if use amd64 || use x86 ; then
+ mycmakeargs+=(
+ -DWITH_AVX2=$(usex cpu_flags_x86_avx2)
+ -DWITH_AVX512=$(usex cpu_flags_x86_avx512f)
+ -DWITH_AVX512VNNI=$(usex cpu_flags_x86_avx512_vnni)
+ -DWITH_SSE2=$(usex cpu_flags_x86_sse2)
+ -DWITH_SSSE3=$(usex cpu_flags_x86_ssse3)
+ -DWITH_SSE42=$(usex cpu_flags_x86_sse4_2)
+ -DWITH_PCLMULQDQ=$(usex cpu_flags_x86_pclmul)
+ -DWITH_VPCLMULQDQ=$(usex cpu_flags_x86_vpclmulqdq)
+ )
+ fi
+
+ if use arm || use arm64 ; then
+ mycmakeargs+=(
+ -DWITH_ACLE=$(usex cpu_flags_arm_crc32)
+ -DWITH_NEON=$(usex cpu_flags_arm_neon)
+ )
+ fi
+
+ if use ppc || use ppc64 ; then
+ # The POWER8 support is VSX which was introduced
+ # VSX2 was introduced with POWER8, so use that as a proxy for it
+ mycmakeargs+=(
+ -DWITH_ALTIVEC=$(usex cpu_flags_ppc_altivec)
+ -DWITH_POWER8=$(usex cpu_flags_ppc_vsx2)
+ -DWITH_POWER9=$(usex cpu_flags_ppc_vsx3)
+ )
+ fi
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ if use compat ; then
+ ewarn "zlib-ng is experimental and replacing the system zlib is dangerous"
+ ewarn "Please be careful!"
+ ewarn
+ ewarn "The following link explains the guarantees (and what is NOT guaranteed):"
+ ewarn "https://github.com/zlib-ng/zlib-ng/blob/2.0.x/PORTING.md"
+ fi
+}