summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 11:01:01 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 11:57:08 +0100
commit2c1a1b03b47894ff9b0f241f80b6612200e44960 (patch)
tree1fd55bfe132e2b0f3b5be14023db9bef391317bb
parentgames-engines/scummvm: Enable readline support for text console (diff)
downloadgentoo-2c1a1b03b47894ff9b0f241f80b6612200e44960.tar.gz
gentoo-2c1a1b03b47894ff9b0f241f80b6612200e44960.tar.bz2
gentoo-2c1a1b03b47894ff9b0f241f80b6612200e44960.zip
games-engines/scummvm: Enable openmpt support
Bug: https://bugs.gentoo.org/946224 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--games-engines/scummvm/metadata.xml1
-rw-r--r--games-engines/scummvm/scummvm-2.9.0.ebuild8
-rw-r--r--games-engines/scummvm/scummvm-9999.ebuild8
3 files changed, 13 insertions, 4 deletions
diff --git a/games-engines/scummvm/metadata.xml b/games-engines/scummvm/metadata.xml
index 06d25e9f94a3..d4e3eb1872f4 100644
--- a/games-engines/scummvm/metadata.xml
+++ b/games-engines/scummvm/metadata.xml
@@ -14,6 +14,7 @@
<flag name="fribidi">Support for right-to-left languages via <pkg>dev-libs/fribidi</pkg></flag>
<flag name="mpeg2">enable mpeg2 codec for cutscenes</flag>
<flag name="net">enable cloud support via <pkg>media-libs/sdl2-net</pkg></flag>
+ <flag name="openmpt">Enable mod/tracker music file support via <pkg>media-libs/libopenmpt</pkg></flag>
<flag name="sndio">Enable support for MIDI music using <pkg>media-sound/sndio</pkg></flag>
<flag name="unsupported">enable unsupported and/or broken game engines (you're on your own)</flag>
<flag name="vpx">Enable VP8/VP9 codec support via <pkg>media-libs/libvpx</pkg></flag>
diff --git a/games-engines/scummvm/scummvm-2.9.0.ebuild b/games-engines/scummvm/scummvm-2.9.0.ebuild
index 440d6e3ed396..f0b6ffc68467 100644
--- a/games-engines/scummvm/scummvm-2.9.0.ebuild
+++ b/games-engines/scummvm/scummvm-2.9.0.ebuild
@@ -21,8 +21,8 @@ LICENSE="GPL-2+ LGPL-2.1 BSD GPL-3-with-font-exception"
SLOT="0"
IUSE="
a52 aac alsa debug flac fluidsynth fribidi gif +gtk jpeg lua mpeg2
- mp3 musepack +net opengl png readline sndio speech theora truetype
- unsupported vorbis vpx zlib
+ mp3 musepack +net opengl openmpt png readline sndio speech theora
+ truetype unsupported vorbis vpx zlib
"
RESTRICT="test" # it only looks like there's a test there #77507
@@ -53,6 +53,7 @@ DEPEND="
media-libs/libglvnd
)
)
+ openmpt? ( media-libs/libopenmpt:= )
png? ( media-libs/libpng:0 )
readline? ( sys-libs/readline:= )
sndio? ( media-sound/sndio:= )
@@ -113,11 +114,14 @@ src_configure() {
$(use_enable gtk)
$(use_enable jpeg)
$(use_enable lua)
+ # it's exclusive to openmpt, and openmpt is preferred upstream
+ --disable-mikmod
$(use_enable mp3 mad)
$(use_enable mpeg2)
$(use_enable musepack mpcdec)
$(use_enable net libcurl)
$(use_enable net sdlnet)
+ $(use_enable openmpt)
$(use_enable png)
$(use_enable readline)
$(use_enable sndio)
diff --git a/games-engines/scummvm/scummvm-9999.ebuild b/games-engines/scummvm/scummvm-9999.ebuild
index 440d6e3ed396..f0b6ffc68467 100644
--- a/games-engines/scummvm/scummvm-9999.ebuild
+++ b/games-engines/scummvm/scummvm-9999.ebuild
@@ -21,8 +21,8 @@ LICENSE="GPL-2+ LGPL-2.1 BSD GPL-3-with-font-exception"
SLOT="0"
IUSE="
a52 aac alsa debug flac fluidsynth fribidi gif +gtk jpeg lua mpeg2
- mp3 musepack +net opengl png readline sndio speech theora truetype
- unsupported vorbis vpx zlib
+ mp3 musepack +net opengl openmpt png readline sndio speech theora
+ truetype unsupported vorbis vpx zlib
"
RESTRICT="test" # it only looks like there's a test there #77507
@@ -53,6 +53,7 @@ DEPEND="
media-libs/libglvnd
)
)
+ openmpt? ( media-libs/libopenmpt:= )
png? ( media-libs/libpng:0 )
readline? ( sys-libs/readline:= )
sndio? ( media-sound/sndio:= )
@@ -113,11 +114,14 @@ src_configure() {
$(use_enable gtk)
$(use_enable jpeg)
$(use_enable lua)
+ # it's exclusive to openmpt, and openmpt is preferred upstream
+ --disable-mikmod
$(use_enable mp3 mad)
$(use_enable mpeg2)
$(use_enable musepack mpcdec)
$(use_enable net libcurl)
$(use_enable net sdlnet)
+ $(use_enable openmpt)
$(use_enable png)
$(use_enable readline)
$(use_enable sndio)