summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-18 14:56:59 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-18 16:03:32 +0200
commit333c59ff6f66231ad9bd69807340c26d3e67f527 (patch)
tree3c342c428103345fd6103dab69b781ba0bcf20d2
parentdev-python/cfn-lint: Bump to 1.14.1 (diff)
downloadgentoo-333c59ff6f66231ad9bd69807340c26d3e67f527.tar.gz
gentoo-333c59ff6f66231ad9bd69807340c26d3e67f527.tar.bz2
gentoo-333c59ff6f66231ad9bd69807340c26d3e67f527.zip
dev-python/jaraco-test: Bump to 5.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jaraco-test/Manifest1
-rw-r--r--dev-python/jaraco-test/jaraco-test-5.5.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/jaraco-test/Manifest b/dev-python/jaraco-test/Manifest
index 4bb20d6aab0f..a4d227779a21 100644
--- a/dev-python/jaraco-test/Manifest
+++ b/dev-python/jaraco-test/Manifest
@@ -1 +1,2 @@
DIST jaraco.test-5.4.0.tar.gz 8838 BLAKE2B 3abdff298a61015363bda3e52d3b5226993169128386dbb620487dcf8b29926c9be0415a2a263ad311db04a591d446b9e6efaece2ab2bfbe7b2781ee2e6dcdd6 SHA512 ab260c3c5ef16e83e8be0821cb735941764c06bb414c3f913bf337b62267b177f3102f7a87241b182ef20760fdcce98f4f9c705335b0744b69f9a296d5215b1b
+DIST jaraco_test-5.5.1.tar.gz 10018 BLAKE2B 09562269a1fd14e099e8bca484f4def00986aa3999134f51f875a026fd5b2832979533e91fcff651d938cbe5c302377152e8bf2288b0afd61ef0a52644c65c92 SHA512 09b3303657ccd6882835e3c0c8e27a03f7c5cfc923318e7c4736eded0a0aa3461f043ab595af82a0bb0de33381924415fd382706ab0af6cea80554ca74873ee1
diff --git a/dev-python/jaraco-test/jaraco-test-5.5.1.ebuild b/dev-python/jaraco-test/jaraco-test-5.5.1.ebuild
new file mode 100644
index 000000000000..d1ca70fa02ec
--- /dev/null
+++ b/dev-python/jaraco-test/jaraco-test-5.5.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Testing support by jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.test/
+ https://pypi.org/project/jaraco.test/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-collections[${PYTHON_USEDEP}]
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/test[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # workaround namespaces blocking test.support import (sigh!)
+ mv jaraco/test jaraco_test || die
+ rmdir jaraco || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ # while technically these tests are skipped when Internet is
+ # not available (they test whether auto-skipping works), we don't
+ # want any Internet access whenever possible
+ local EPYTEST_DESELECT=(
+ tests/test_http.py::test_needs_internet
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not network"
+}