summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-24 07:18:57 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-24 08:04:08 +0100
commit44683e33391e660e0b7b471cfeb644d6aaf0142e (patch)
tree91b61f76d5501cdfbdd81be842a2277315ec2c44
parentdev-python/aws-sam-translator: Bump to 1.58.0 (diff)
downloadgentoo-44683e33391e660e0b7b471cfeb644d6aaf0142e.tar.gz
gentoo-44683e33391e660e0b7b471cfeb644d6aaf0142e.tar.bz2
gentoo-44683e33391e660e0b7b471cfeb644d6aaf0142e.zip
dev-python/python-nbxmpp: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-nbxmpp/Manifest1
-rw-r--r--dev-python/python-nbxmpp/python-nbxmpp-4.1.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-nbxmpp/Manifest b/dev-python/python-nbxmpp/Manifest
index f1634ec245e4..79cd37f0e08b 100644
--- a/dev-python/python-nbxmpp/Manifest
+++ b/dev-python/python-nbxmpp/Manifest
@@ -1,3 +1,4 @@
DIST python-nbxmpp-3.2.5.tar.bz2 132029 BLAKE2B 846f3b47c3a9a95cf1fa1b557a007fd4901fb4acaa3160ea4b9b1cdff1e9d2c3e64bc5251b739d816f3f1c449c350d1ac44c14cbef87d14fe5a6450418451007 SHA512 577f8c7b0f5a7c69b4d980bff93f0a208ab0a660d731eb95ec63b76583194b94bd9d9f6b10fcac3951a6e6afb5d0c4da2140cbc17ef653f19ec6957b5d2e5f04
DIST python-nbxmpp-4.0.0.tar.bz2 133902 BLAKE2B 8b86f58f5a21a5e4f473528fe61f0f7db8d3cdeb4bad5f5c98d6acafbc3ef30794431cd2bb437754549b3bee21252cbdbf37e69c20461a5facc0b455f631edaa SHA512 3eb9433529d2971f495bf683d586bca63c238eef96f5f6c6082d02a8fb0d11374302ddc0f718a7ff73db624d3aa3a8325d157b80679c165077dbb9d4dc490e3a
DIST python-nbxmpp-4.0.1.tar.bz2 133863 BLAKE2B 83fbe4b84b47fd4215e5041d28c24fbf230f56f6bf097e83983dc5c48b92f520a36d02636cb0a76eb5a97f04df7c0869c4a59b124354b484697b78aafbc45a8d SHA512 eb9907d5d985ed72a0b4d004e3f2e607e4786a826fc2b5a612a695af3f4d3ca5e4edb127e9bf14edf2f52e7902a80f5c9958bf3cc6ade4446d2aa117b4422aee
+DIST python-nbxmpp-4.1.0.tar.bz2 132973 BLAKE2B b28b7e24debecd5088234d8eb862aebdbd461511c02f0bf8b45429c3b1964706046fdc773d654b4dce7a6ec62cc1f58e5caf9f9ef2cc0c58603129232e658325 SHA512 fd977ba9e4795abec8e1367462e7ae8c38671deea1e40849e84350bdab8281595f839848a8dff6fa730f65c5b60d82826b4d660ca2f14519ce2db0bd5f092782
diff --git a/dev-python/python-nbxmpp/python-nbxmpp-4.1.0.ebuild b/dev-python/python-nbxmpp/python-nbxmpp-4.1.0.ebuild
new file mode 100644
index 000000000000..9c623ff343b7
--- /dev/null
+++ b/dev-python/python-nbxmpp/python-nbxmpp-4.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to use Jabber/XMPP networks in a non-blocking way"
+HOMEPAGE="
+ https://dev.gajim.org/gajim/python-nbxmpp/
+ https://pypi.org/project/nbxmpp/
+"
+SRC_URI="
+ https://dev.gajim.org/gajim/python-nbxmpp/-/archive/${PV}/${P}.tar.bz2
+"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ net-libs/libsoup:3.0[introspection]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/precis-i18n-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest