summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-28 07:24:23 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-28 07:57:39 +0100
commit5a5fe38a2b043a15178646e14b5a4b27051ddbaa (patch)
tree1c4a56106c6e9d00987e0d67e03d927fbe4266d3
parentdev-python/cmd2: Bump to 2.4.3 (diff)
downloadgentoo-5a5fe38a2b043a15178646e14b5a4b27051ddbaa.tar.gz
gentoo-5a5fe38a2b043a15178646e14b5a4b27051ddbaa.tar.bz2
gentoo-5a5fe38a2b043a15178646e14b5a4b27051ddbaa.zip
dev-python/rst-linker: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rst-linker/Manifest1
-rw-r--r--dev-python/rst-linker/rst-linker-2.4.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/rst-linker/Manifest b/dev-python/rst-linker/Manifest
index 1c702e03a8fb..eb93cf3d1a69 100644
--- a/dev-python/rst-linker/Manifest
+++ b/dev-python/rst-linker/Manifest
@@ -1 +1,2 @@
DIST rst.linker-2.3.1.tar.gz 10436 BLAKE2B 0de71c1994b65c20f2ef13e1e8f9f04d431d9bd7215ca9dca2c51d78deaa55803f69432d27dd14b3b5f9d224b75f72a56ac4bba72ec3fad660af31b248a265ba SHA512 0c9f236e372ffe69c2b37983c491c5b6fdb41f1c2a4ac16d3d815bfe5e8b93b58f001d449a57e663041d69d0e13e13d17178c477a1ea37f05ba7e919fcee698c
+DIST rst.linker-2.4.0.tar.gz 11340 BLAKE2B a1ae9c811b7d6fa2821bfbf5787dce75fd3d7e5d933ec15fbac9cd3bde08cfad59fdc81b3b58dc39d1209a27ca9dd8d2ecd68034b434b3f6d15469bfb98efa3d SHA512 31e3427ecf35b433cc9650138ee36090e99003b72c69b60b530835eb624d7eb13aae4cf81cc0044b36750798a4b8aa676e53e3b9eb335430076593640a243940
diff --git a/dev-python/rst-linker/rst-linker-2.4.0.ebuild b/dev-python/rst-linker/rst-linker-2.4.0.ebuild
new file mode 100644
index 000000000000..af00fd4c42e9
--- /dev/null
+++ b/dev-python/rst-linker/rst-linker-2.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Sphinx plugin to add links and timestamps to the changelog"
+HOMEPAGE="
+ https://github.com/jaraco/rst.linker/
+ https://pypi.org/project/rst.linker/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/path[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest