summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-26 09:04:18 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-26 09:22:28 +0100
commit5d60d799152d3a4af2adb20759408cd0a1f67cc0 (patch)
tree4791aff830e225b518dc6d007c2163cc3f250ec0
parentdev-python/aiosmtpd: Bump to 1.4.0 (diff)
downloadgentoo-5d60d799152d3a4af2adb20759408cd0a1f67cc0.tar.gz
gentoo-5d60d799152d3a4af2adb20759408cd0a1f67cc0.tar.bz2
gentoo-5d60d799152d3a4af2adb20759408cd0a1f67cc0.zip
dev-python/xarray: Bump to 0.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/xarray/Manifest1
-rw-r--r--dev-python/xarray/xarray-0.17.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index a997479fcd72..dfdc8fc92b5c 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1 +1,2 @@
DIST xarray-0.16.2.tar.gz 2018053 BLAKE2B 3b95c688a3979323b93ec46c9f218795fbf9df56a7ba1459a507ac36379b3240c351cbb3f1907a204199c6c0c4c0c1c516552548d1e03fb987ad718561aa9772 SHA512 f6cd3eee2012e3b544874388c4824e911ce5d213cd393bf01b10deb9742a1168f41629e4f1e49220228771cac920980eaa98a599a6d62c383dd3da7b3bfe0dd8
+DIST xarray-0.17.0.tar.gz 2055584 BLAKE2B afbd28032069e4b498c87abd34661dc96525cb581a08fcf68eeaca08468afb9b452650bce4d21cada0eb1cb75ad11b0565a6b965b11120d4bef4d4cd612fa91d SHA512 726d548519614936f4b6c6ded0375a35362b195a2c6b55a282d198cbb8a70fa7439377a88f253cf4f16c86582fc22c8a4700b9645516decf7edd3e980d9dda34
diff --git a/dev-python/xarray/xarray-0.17.0.ebuild b/dev-python/xarray/xarray-0.17.0.ebuild
new file mode 100644
index 000000000000..894b1d80800a
--- /dev/null
+++ b/dev-python/xarray/xarray-0.17.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# pkg_resources use in code
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="https://xarray.pydata.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.0[${PYTHON_USEDEP}]"
+# note: most of test dependencies are optional
+BDEPEND="
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.4[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest