summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-06 16:07:05 +0000
committerSam James <sam@gentoo.org>2024-12-06 16:07:05 +0000
commit6670383db1351adec3104a159747a54a9943d0d8 (patch)
treeb0bfabe2aa72c25385f30a4cc81c10aa500c74bf
parentsys-libs/readline: pass -std=gnu17 conditionally for old too (diff)
downloadgentoo-6670383db1351adec3104a159747a54a9943d0d8.tar.gz
gentoo-6670383db1351adec3104a159747a54a9943d0d8.tar.bz2
gentoo-6670383db1351adec3104a159747a54a9943d0d8.zip
dev-vcs/git: pass -std=gnu17 conditionally
Old compilers during Prefix bootstrap may not support it but they also won't be defaulting to C23 so that's fine. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-vcs/git/git-2.47.0-r1.ebuild2
-rw-r--r--dev-vcs/git/git-2.47.1.ebuild2
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild2
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild2
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild2
-rw-r--r--dev-vcs/git/git-9999.ebuild2
6 files changed, 6 insertions, 6 deletions
diff --git a/dev-vcs/git/git-2.47.0-r1.ebuild b/dev-vcs/git/git-2.47.0-r1.ebuild
index 02512210c101..6ffa3da84ef2 100644
--- a/dev-vcs/git/git-2.47.0-r1.ebuild
+++ b/dev-vcs/git/git-2.47.0-r1.ebuild
@@ -327,7 +327,7 @@ git_emake() {
src_configure() {
# https://lore.kernel.org/git/87ed3apy2u.fsf@gentoo.org/
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
exportmakeopts
}
diff --git a/dev-vcs/git/git-2.47.1.ebuild b/dev-vcs/git/git-2.47.1.ebuild
index 39ba0bb5efe7..9701a056aae7 100644
--- a/dev-vcs/git/git-2.47.1.ebuild
+++ b/dev-vcs/git/git-2.47.1.ebuild
@@ -324,7 +324,7 @@ git_emake() {
src_configure() {
# https://lore.kernel.org/git/87ed3apy2u.fsf@gentoo.org/
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
exportmakeopts
}
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 39ba0bb5efe7..9701a056aae7 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -324,7 +324,7 @@ git_emake() {
src_configure() {
# https://lore.kernel.org/git/87ed3apy2u.fsf@gentoo.org/
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
exportmakeopts
}
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 39ba0bb5efe7..9701a056aae7 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -324,7 +324,7 @@ git_emake() {
src_configure() {
# https://lore.kernel.org/git/87ed3apy2u.fsf@gentoo.org/
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
exportmakeopts
}
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 39ba0bb5efe7..9701a056aae7 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -324,7 +324,7 @@ git_emake() {
src_configure() {
# https://lore.kernel.org/git/87ed3apy2u.fsf@gentoo.org/
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
exportmakeopts
}
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 39ba0bb5efe7..9701a056aae7 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -324,7 +324,7 @@ git_emake() {
src_configure() {
# https://lore.kernel.org/git/87ed3apy2u.fsf@gentoo.org/
- append-cflags -std=gnu17
+ append-cflags $(test-flags-CC -std=gnu17)
exportmakeopts
}