summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-10 09:46:33 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-10 10:43:23 +0300
commit740725659c15a534468ba67c356429a9dccd6838 (patch)
tree8ca56797ff3e047ace54c03ad3606fe03d1bcdde
parentdev-python/apsw: add 3.39.4.0 (diff)
downloadgentoo-740725659c15a534468ba67c356429a9dccd6838.tar.gz
gentoo-740725659c15a534468ba67c356429a9dccd6838.tar.bz2
gentoo-740725659c15a534468ba67c356429a9dccd6838.zip
dev-python/patsy: add 0.5.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/patsy/Manifest1
-rw-r--r--dev-python/patsy/patsy-0.5.3.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/patsy/Manifest b/dev-python/patsy/Manifest
index 67873491e698..1a4b898c0d39 100644
--- a/dev-python/patsy/Manifest
+++ b/dev-python/patsy/Manifest
@@ -1 +1,2 @@
DIST patsy-0.5.2.tar.gz 397275 BLAKE2B 3aa5dc310729bd979c78004d5f1badb83b75b08d290cf8258191c87d61401f0b6ecd9490f1c4b932269e545c50a16694e44de9c076ca80648717c5f1af62fb69 SHA512 898df5536b0ff3a4d299e69c5f73a3d754cfbe78fe463fb4c4726cfd67d4e30c77cd3d7093131737207cb9f29c1374ab20a68ec5978007ea51878ec7c395f48d
+DIST patsy-0.5.3.tar.gz 397680 BLAKE2B 43696f9e95c124cab5bf907723596d8b2b15f0539fbd2b9c2a2fcc76591e935020929ba31fd5378114fe58d22a9931508d89edf21f24b00c916a6e78dc4ee58f SHA512 9a6ea2382287208013e02bab7cba9378311a8e18fe059593aa99090bb6191efa74badff011424a7f6b3c8ec72c1b8650637322b71617f23357bb4b38ac6a79a0
diff --git a/dev-python/patsy/patsy-0.5.3.ebuild b/dev-python/patsy/patsy-0.5.3.ebuild
new file mode 100644
index 000000000000..14d0d4386090
--- /dev/null
+++ b/dev-python/patsy/patsy-0.5.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python module to describe statistical models and design matrices"
+HOMEPAGE="https://patsy.readthedocs.io/en/latest/index.html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !hppa? ( dev-python/scipy[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest