summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-05-27 14:09:11 -0300
committerMatt Turner <mattst88@gentoo.org>2023-05-30 11:51:32 -0400
commit79dbf2b0ddea6443fdac6d7a7b28051103d76aa5 (patch)
tree6b6420bf58d81f0f9554946198d81fa19db24265
parentgnome-extra/gnome-boxes: Version bump to 44.2 (diff)
downloadgentoo-79dbf2b0ddea6443fdac6d7a7b28051103d76aa5.tar.gz
gentoo-79dbf2b0ddea6443fdac6d7a7b28051103d76aa5.tar.bz2
gentoo-79dbf2b0ddea6443fdac6d7a7b28051103d76aa5.zip
app-accessibility/at-spi2-core: Version bump to 2.48.3
Closes: https://bugs.gentoo.org/699958 Closes: https://github.com/gentoo/gentoo/pull/31187 Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-accessibility/at-spi2-core/Manifest1
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.48.3.ebuild75
-rw-r--r--app-accessibility/at-spi2-core/metadata.xml3
-rw-r--r--profiles/arch/alpha/package.use.mask4
-rw-r--r--profiles/arch/arm/package.use.mask4
-rw-r--r--profiles/arch/hppa/package.use.mask4
-rw-r--r--profiles/arch/ia64/package.use.mask4
-rw-r--r--profiles/arch/loong/package.use.mask4
-rw-r--r--profiles/arch/mips/package.use.mask4
-rw-r--r--profiles/arch/powerpc/ppc32/package.use.mask4
-rw-r--r--profiles/arch/riscv/package.use.stable.mask6
-rw-r--r--profiles/arch/s390/package.use.mask4
-rw-r--r--profiles/arch/sparc/package.use.mask4
-rw-r--r--profiles/arch/x86/package.use.mask4
-rw-r--r--profiles/features/musl/package.use.mask4
15 files changed, 129 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-core/Manifest b/app-accessibility/at-spi2-core/Manifest
index 752c007d9333..71d5c9b68411 100644
--- a/app-accessibility/at-spi2-core/Manifest
+++ b/app-accessibility/at-spi2-core/Manifest
@@ -1,2 +1,3 @@
DIST at-spi2-core-2.48.0.tar.xz 554000 BLAKE2B b8f513256670d24ae9f08572ae7878f109b5d76090fa4f881b67324d1d270889c648e456fe3ca34aaead9e85589f5ae355c8b4803f35c2cb2ace831051b1000b SHA512 976dce741d640c5b5e006eca53170062ebc91cace0fb74df68606c8443b63317fe271d4e3238d1e3ee3e5586b4a4905c91d7987adb94c8f886a1aaddd54c632e
DIST at-spi2-core-2.48.2.tar.xz 554056 BLAKE2B 3e499c155a6d8780cb08a714521b530353f8e8a507c42acfbab89ea637413f17f5ecb431574eb862ac47d465f80320f04dedeced0547c0f057b426ea763f6c81 SHA512 e30c9873965bee057eab33b787588a709ba775213c8d9b2ba5382e91be48aa86bedb7d268cb4e07a3980c12a673811f94a423dbaa83fd32c1702a0cbbddb8b44
+DIST at-spi2-core-2.48.3.tar.xz 554388 BLAKE2B 9692df8cc0bc8de82f6e339b9358be7ab1bc598afdb39503f5f05ca772109b962a513fe2ef79d8f094ea732457225409f3c765784a54cbabf27b8fc72c893eb9 SHA512 e79ef0eb0f23241d61ba2a62f4024a5df5ff7125bc085590f9038b3397d255b88b8266deec14f3fe53bee4072ab85695a47d27d8be0529b18a103ad792fa0e54
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.48.3.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.48.3.ebuild
new file mode 100644
index 000000000000..5aabf7fa9bcd
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.48.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson-multilib systemd virtualx xdg
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="https://wiki.gnome.org/Accessibility https://gitlab.gnome.org/GNOME/at-spi2-core"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="X dbus-broker gtk-doc +introspection systemd"
+REQUIRED_USE="
+ dbus-broker? ( systemd )
+ gtk-doc? ( X )
+"
+
+DEPEND="
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.67.4:2[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54.0:= )
+ systemd? ( sys-apps/systemd[${MULTILIB_USEDEP}] )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ )
+
+ !<dev-libs/atk-2.46.0
+ !<app-accessibility/at-spi2-atk-2.46.0
+"
+RDEPEND="${DEPEND}
+ dbus-broker? ( sys-apps/dbus-broker )
+"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ dev-python/sphinx
+ dev-util/gdbus-codegen
+ >=dev-util/gi-docgen-2021.1
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_bus=$(usex dbus-broker dbus-broker dbus-daemon)
+ $(meson_use systemd use_systemd)
+ -Dsystemd_user_dir="$(systemd_get_userunitdir)"
+ $(meson_native_use_bool gtk-doc docs)
+ $(meson_native_use_feature introspection)
+ $(meson_feature X x11)
+ -Ddisable_p2p=false
+ -Datk_only=false
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx dbus-run-session meson test -C "${BUILD_DIR}" || die
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/{libatspi,atk} || die
+ mv "${ED}"/usr/share/doc/libatspi "${ED}"/usr/share/gtk-doc/libatspi/html || die
+ mv "${ED}"/usr/share/doc/atk "${ED}"/usr/share/gtk-doc/atk/html || die
+ fi
+}
diff --git a/app-accessibility/at-spi2-core/metadata.xml b/app-accessibility/at-spi2-core/metadata.xml
index 32089b0df716..82e71a3a93ce 100644
--- a/app-accessibility/at-spi2-core/metadata.xml
+++ b/app-accessibility/at-spi2-core/metadata.xml
@@ -8,4 +8,7 @@
<upstream>
<remote-id type="gnome-gitlab">GNOME/at-spi2-core</remote-id>
</upstream>
+ <use>
+ <flag name="dbus-broker">Use DBus broker implementation instead of default DBus daemon</flag>
+ </use>
</pkgmetadata>
diff --git a/profiles/arch/alpha/package.use.mask b/profiles/arch/alpha/package.use.mask
index 3432f1a51219..2def3ed90c46 100644
--- a/profiles/arch/alpha/package.use.mask
+++ b/profiles/arch/alpha/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2023-05-30)
+# sys-apps/dbus-broker is not keyworded
+app-accessibility/at-spi2-core dbus-broker
+
# Sam James <sam@gentoo.org> (2023-05-01)
# media-libs/libjxl is not keyworded
# bug https://bugs.gentoo.org/853628
diff --git a/profiles/arch/arm/package.use.mask b/profiles/arch/arm/package.use.mask
index 41fa484485e7..7ae4cfed9881 100644
--- a/profiles/arch/arm/package.use.mask
+++ b/profiles/arch/arm/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2023-05-30)
+# sys-apps/dbus-broker is not keyworded
+app-accessibility/at-spi2-core dbus-broker
+
# Sam James <sam@gentoo.org> (2023-05-10)
# sys-cluster/ceph not keyworded here
sys-block/tgt rbd
diff --git a/profiles/arch/hppa/package.use.mask b/profiles/arch/hppa/package.use.mask
index 80a121bcef50..12b5176c0759 100644
--- a/profiles/arch/hppa/package.use.mask
+++ b/profiles/arch/hppa/package.use.mask
@@ -4,6 +4,10 @@
# NOTE: When masking a USE flag due to missing keywords, please file a keyword
# request bug for the hppa arch.
+# Matt Turner <mattst88@gentoo.org> (2023-05-30)
+# sys-apps/dbus-broker is not keyworded
+app-accessibility/at-spi2-core dbus-broker
+
# Michał Górny <mgorny@gentoo.org> (2023-05-20)
# Requires dev-python/sphinx-autodoc-types that has unkeyworded depgraph.
dev-python/jupyter-core doc
diff --git a/profiles/arch/ia64/package.use.mask b/profiles/arch/ia64/package.use.mask
index 14c693a8d3bf..fa01a4f95691 100644
--- a/profiles/arch/ia64/package.use.mask
+++ b/profiles/arch/ia64/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2023-05-30)
+# sys-apps/dbus-broker is not keyworded
+app-accessibility/at-spi2-core dbus-broker
+
# Sam James <sam@gentoo.org> (2023-04-17)
# net-misc/pps-tools is not keyworded here
net-misc/chrony pps
diff --git a/profiles/arch/loong/package.use.mask b/profiles/arch/loong/package.use.mask
index f8cd99f2956f..255f75492abe 100644
--- a/profiles/arch/loong/package.use.mask
+++ b/profiles/arch/loong/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2023-05-30)
+# sys-apps/dbus-broker is not keyworded
+app-accessibility/at-spi2-core dbus-broker
+
# Mike Gilbert <floppym@gentoo.org> (2023-05-27)
# Newer sd-boot does not use gnuefi.
>=sys-apps/systemd-254 -boot
diff --git a/profiles/arch/mips/package.use.mask b/profiles/arch/mips/package.use.mask
index dfaf83be4cb6..052fb6544943 100644
--- a/profiles/arch/mips/package.use.mask
+++ b/profiles/arch/mips/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2023-05-30)
+# sys-apps/dbus-broker is not keyworded
+app-accessibility/at-spi2-core dbus-broker
+
# matoro <matoro_gentoo@matoro.tk> (2023-03-03)
# virtual/jdk isn't keyworded here
media-libs/rubberband jni
diff --git a/profiles/arch/powerpc/ppc32/package.use.mask b/profiles/arch/powerpc/ppc32/package.use.mask
index 74d799285634..5d8be8ed040c 100644
--- a/profiles/arch/powerpc/ppc32/package.use.mask
+++ b/profiles/arch/powerpc/ppc32/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2023-05-30)
+# sys-apps/dbus-broker is not keyworded
+app-accessibility/at-spi2-core dbus-broker
+
# Sam James <sam@gentoo.org> (2023-05-19)
# kde-frameworks/kwayland:5 is not keyworded here.
app-crypt/pinentry wayland
diff --git a/profiles/arch/riscv/package.use.stable.mask b/profiles/arch/riscv/package.use.stable.mask
new file mode 100644
index 000000000000..be1d074b6773
--- /dev/null
+++ b/profiles/arch/riscv/package.use.stable.mask
@@ -0,0 +1,6 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Matt Turner <mattst88@gentoo.org> (2023-05-30)
+# sys-apps/dbus-broker is not stable
+app-accessibility/at-spi2-core dbus-broker
diff --git a/profiles/arch/s390/package.use.mask b/profiles/arch/s390/package.use.mask
index 41ac083218a1..348be7575f72 100644
--- a/profiles/arch/s390/package.use.mask
+++ b/profiles/arch/s390/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2023-05-30)
+# sys-apps/dbus-broker is not keyworded
+app-accessibility/at-spi2-core dbus-broker
+
# Sam James <sam@gentoo.org> (2023-05-01)
# media-libs/libjxl is not keyworded
# bug https://bugs.gentoo.org/853628
diff --git a/profiles/arch/sparc/package.use.mask b/profiles/arch/sparc/package.use.mask
index 82891f189646..87f3faf38b00 100644
--- a/profiles/arch/sparc/package.use.mask
+++ b/profiles/arch/sparc/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2023-05-30)
+# sys-apps/dbus-broker is not keyworded
+app-accessibility/at-spi2-core dbus-broker
+
# Arsen Arsenović <arsen@gentoo.org> (2023-05-17)
# app-emulation/libguestfs pulls in a large amount of dependencies, most
# of which aren't or can't be kw'd on SPARC.
diff --git a/profiles/arch/x86/package.use.mask b/profiles/arch/x86/package.use.mask
index 97e091ab7dea..5cf40817952c 100644
--- a/profiles/arch/x86/package.use.mask
+++ b/profiles/arch/x86/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2023-05-30)
+# sys-apps/dbus-broker is not keyworded
+app-accessibility/at-spi2-core dbus-broker
+
# Anna Vyalkova <cyber+gentoo@sysrq.in> (2023-05-20)
# net-libs/libomemo-c is not keyworded for ~x86.
net-libs/qxmpp omemo
diff --git a/profiles/features/musl/package.use.mask b/profiles/features/musl/package.use.mask
index 269ec2307904..793b7cb79960 100644
--- a/profiles/features/musl/package.use.mask
+++ b/profiles/features/musl/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2023-05-30)
+# sys-apps/dbus-broker is masked on musl
+app-accessibility/at-spi2-core dbus-broker
+
# Sam James <sam@gentoo.org> (2023-05-08)
# Needs fpu_control.h, bug #891063
media-sound/lame debug