summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-16 10:16:55 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-16 10:16:55 +0100
commit7d67ce33cf4adf35282b2ba7aaf355f1745e6dd0 (patch)
tree3a4317cc320f7d8234515cd977d84a81f93fc975
parentdev-python/botocore: Bump to 1.24.20 (diff)
downloadgentoo-7d67ce33cf4adf35282b2ba7aaf355f1745e6dd0.tar.gz
gentoo-7d67ce33cf4adf35282b2ba7aaf355f1745e6dd0.tar.bz2
gentoo-7d67ce33cf4adf35282b2ba7aaf355f1745e6dd0.zip
dev-python/boto3: Bump to 1.21.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.21.20.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 96752f409337..f28570b58609 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,4 +2,5 @@ DIST boto3-1.21.15.tar.gz 476516 BLAKE2B 306c7ee69dec5ff1fbd76ed32aaebdf0f52cdc4
DIST boto3-1.21.16.tar.gz 476669 BLAKE2B 5ff8130a168841cd885f1f3f4752a5362910f0fd3c0598bab9db6f36c91570b4ef2ef598c46ebc5af870d9a12f12343213d44786923b3e0388bcc929d51fbca9 SHA512 86abc6903761ef740e3144a70acc9c3ef6f06e980a81b5384f8ad382080e8a5865df4e84b04ad54d6160ac2e9b7e1ff088395508ceb80861177f55b3a4eeeaab
DIST boto3-1.21.18.tar.gz 477263 BLAKE2B 3d27a261bca3b7dbbab2eadd5be686e5b87b297a7a243d27a5424195e027abfb8e378296e760104f5de48a2e1a860bde5b658f7ff4c64520eab3df9f85bf78ae SHA512 4750a5ad6858df03c5c5367035de02f5a0123f46397992a7573542f5348eb0d864e3bbd6e009d7a62ccedef0316d1a2443649a87e922aa9c6dbdc4e1c9238e59
DIST boto3-1.21.19.tar.gz 477903 BLAKE2B e06fdbcaf94a2c30efec86883b281d83363eeb643b09c894c678ba506f9ab3c85e0d807db61a9f26cf08c4bc7ecc563b6ad4b841be04c3055ae681eb5a8733cb SHA512 fbc29d04da1962c2cff2e4be568bc0eb2199181731e5028b848152d224f2bd1dcc0c53c9098762fa69189df1fc4d5ed99ac45fb631c9b37b3c911184167b1c31
+DIST boto3-1.21.20.tar.gz 478803 BLAKE2B a10b40e73b40933de94b6b33dfb76588cc7f614041f0128add3b1c9d0e30da77338cadef25b8f952e6a0eff9ad8f8248b44d4e70070ea793e2f1d0b1d96d81ae SHA512 37d3269e05727a08d1e288f8eee8fd6824d869cefce67a58323b4ffa89cc458a6de94438db204d49e037215659d0b29da2f03b59d7159bbc6492328099a87147
DIST boto3-1.21.8.tar.gz 473069 BLAKE2B f08f76fb9c4e56e6ba5624c885973599505769d7f9eea6e20a06e1a641768b1f7b108fc7293282a55bf4c7d2b62eb34853f46b8c3ada9afb8fc25624daa60c12 SHA512 23ed88dcaefe3224db05959251befaae4f03859bf00daf649db1e838e5fb92e01a6da4bee8083366d804404aac358df19d7e4552d6aaf39f9c4b371ccc7f9088
diff --git a/dev-python/boto3/boto3-1.21.20.ebuild b/dev-python/boto3/boto3-1.21.20.ebuild
new file mode 100644
index 000000000000..6fcba460ab1d
--- /dev/null
+++ b/dev-python/boto3/boto3-1.21.20.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}