summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-01 11:44:51 +0000
committerSam James <sam@gentoo.org>2021-06-01 11:55:55 +0000
commit7f0edbd0c2762a3aeec77a6d34ed8092d37b86d7 (patch)
tree4565e5f66e851ff1b57e139525d17f79f007d371
parentsci-mathematics/singular: fix CFLAGS/CXXFLAGS support, mostly. (diff)
downloadgentoo-7f0edbd0c2762a3aeec77a6d34ed8092d37b86d7.tar.gz
gentoo-7f0edbd0c2762a3aeec77a6d34ed8092d37b86d7.tar.bz2
gentoo-7f0edbd0c2762a3aeec77a6d34ed8092d37b86d7.zip
dev-python/pytest-html: add Python 3.9
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pytest-html/pytest-html-1.22.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/pytest-html/pytest-html-1.22.1.ebuild b/dev-python/pytest-html/pytest-html-1.22.1.ebuild
index ff9bd0ca538c..46e90071e9a8 100644
--- a/dev-python/pytest-html/pytest-html-1.22.1.ebuild
+++ b/dev-python/pytest-html/pytest-html-1.22.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} pypy3 )
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
inherit distutils-r1
DESCRIPTION="Plugin for generating HTML reports for py.test results"
@@ -13,9 +13,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+
# Lots of test failures...
RESTRICT="test"
+
RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-metadata[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}