summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-09-12 12:09:43 +0000
committerYixun Lan <dlan@gentoo.org>2024-09-12 12:11:58 +0000
commit7f5d4c75a6e10b7ec7d7f371940f342c10b5a7b1 (patch)
tree2631ee46f5584b28a925d4bc0e2610f3d5812aba
parentdev-lang/boogie: bump to 3.2.5 (diff)
downloadgentoo-7f5d4c75a6e10b7ec7d7f371940f342c10b5a7b1.tar.gz
gentoo-7f5d4c75a6e10b7ec7d7f371940f342c10b5a7b1.tar.bz2
gentoo-7f5d4c75a6e10b7ec7d7f371940f342c10b5a7b1.zip
net-vpn/candy: add 5.10.4
Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--net-vpn/candy/Manifest1
-rw-r--r--net-vpn/candy/candy-5.10.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-vpn/candy/Manifest b/net-vpn/candy/Manifest
index 5c32f1d0d2a1..8be113b96228 100644
--- a/net-vpn/candy/Manifest
+++ b/net-vpn/candy/Manifest
@@ -1 +1,2 @@
DIST candy-5.10.3.gh.tar.gz 115258 BLAKE2B 70d698d69fbb0a28adeb1ba515a1a1f6986c083d3a04b688bfd5b7ead98941bac46af47cd745b74928fc56466ebe3fa7d570f7ecaa1716b2eac948d9eaf52fe2 SHA512 c56ab81f599c5fbf72c509265b3fc0189a17e36b8738e536f21702585e7994c706a277d8c1dbf8b68e7f3609518fec0b4daccc0b180d375463e898bb7d41bbdc
+DIST candy-5.10.4.gh.tar.gz 115673 BLAKE2B d150cdf06cd003f0d42e176538a204b8c4cab114bde2c363162a8a75d22e7911abf6a0944a142d6be5ee49116dc24b61d20588390dff7496b51995079ed05457 SHA512 09653777c4653c786d03d8a2141988e1b6f33f0b81b46815d3c13e7d7ca40957d15d654a7d58dd72f02574197183e9198563e871ab4d23f228f87a81cccd0b2d
diff --git a/net-vpn/candy/candy-5.10.4.ebuild b/net-vpn/candy/candy-5.10.4.ebuild
new file mode 100644
index 000000000000..36c322c1a7fa
--- /dev/null
+++ b/net-vpn/candy/candy-5.10.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake systemd readme.gentoo-r1
+
+DESCRIPTION="A reliable, low-latency, and anti-censorship virtual private network"
+HOMEPAGE="https://github.com/lanthora/candy"
+SRC_URI="https://github.com/lanthora/candy/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+DEPEND="
+ dev-libs/poco
+ dev-libs/openssl:0=
+ dev-libs/spdlog
+ dev-libs/libfmt
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_install(){
+ cmake_src_install
+ default
+
+ insinto /etc
+ doins candy.cfg
+
+ systemd_dounit candy.service
+ systemd_dounit candy@.service
+ newinitd candy.initd candy
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}