summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-21 17:46:12 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-21 20:04:54 +0100
commit8982d1f49c72316e8e2897e540d5582949405d17 (patch)
tree97d0a71c00cc43a0c69fc5716130e503ada3133d
parentdev-python/setuptools: Bump to 69.0.1 (diff)
downloadgentoo-8982d1f49c72316e8e2897e540d5582949405d17.tar.gz
gentoo-8982d1f49c72316e8e2897e540d5582949405d17.tar.bz2
gentoo-8982d1f49c72316e8e2897e540d5582949405d17.zip
dev-python/ensurepip-setuptools: Bump to 69.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ensurepip-setuptools/Manifest1
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-69.0.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ensurepip-setuptools/Manifest b/dev-python/ensurepip-setuptools/Manifest
index 381980d0266c..cdbe78880aa3 100644
--- a/dev-python/ensurepip-setuptools/Manifest
+++ b/dev-python/ensurepip-setuptools/Manifest
@@ -1,2 +1,3 @@
DIST setuptools-68.2.2-py3-none-any.whl 807864 BLAKE2B 1ae4dab8a589c95281cac145c3e06b4027b585065a5191a9d6dd9c77730a096b592154863c555d8098c10425dfef315de3b79c6b631e8f6aacc0f234795f95fc SHA512 6e0d854040baff861e1647d2bece7d090bc793b2bd9819c56105b94090df54881a6a9b43ebd82578cd7c76d47181571b671e60672afd9def389d03c9dae84fcf
DIST setuptools-69.0.0-py3-none-any.whl 819391 BLAKE2B 69b296d3f91a9aa35b9f01a3a9a49625677a9fc292163fbeac7e97b9ac7b2ac1a592feaf5c638705a8a586498f32adef187f24ed8f122014431a3c96f5d1c3bb SHA512 e52aeabb115aa65340b94ac4cede3c21b6a07f770fc2f17a59cc876557ee29f82d9149055b9c729b328271983bf0089f1b8392b4a77c9452bec2a0ff13cf353f
+DIST setuptools-69.0.1-py3-none-any.whl 819395 BLAKE2B bc209ba01605de0075771f62dfd3b103cb11e937aa38cca35af8fd1e77aa87f488d3c5b2ec3800616db1997b731d617e376e7ec2967191d349816d26d37bc565 SHA512 d19c7cec1e8d18c6e151f7d67b7b26abf26ce9f5f4a2ebc82ab983ba3b5efae4a657020fff279f7cca56c1f8a3b4564f86eb161b68069994e8543568793776f5
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-69.0.1.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-69.0.1.ebuild
new file mode 100644
index 000000000000..8346a1bd0f6d
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-69.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pypi
+
+DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/setuptools/"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
+S=${DISTDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${A}"
+}