summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-10 05:04:04 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-10 05:04:04 +0100
commit8f507c354a43854655566b7ad61d67a14a5a8907 (patch)
treef5e074abbb60d43dbeab59fc0d1387650660f178
parentdev-python/google-api-core: Bump to 2.14.0 (diff)
downloadgentoo-8f507c354a43854655566b7ad61d67a14a5a8907.tar.gz
gentoo-8f507c354a43854655566b7ad61d67a14a5a8907.tar.bz2
gentoo-8f507c354a43854655566b7ad61d67a14a5a8907.zip
dev-python/makefun: Bump to 1.15.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/makefun/Manifest1
-rw-r--r--dev-python/makefun/makefun-1.15.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/makefun/Manifest b/dev-python/makefun/Manifest
index 31183eec2c06..920ab7eee809 100644
--- a/dev-python/makefun/Manifest
+++ b/dev-python/makefun/Manifest
@@ -1 +1,2 @@
DIST makefun-1.15.1.tar.gz 74521 BLAKE2B e5ea20d64cebadedc63af851fd988f4b5102ea802215e87e23b5f9452bef5356f027f71853658b95caf85b6ff2c5497a8769c8e52b1d2d0c141029e1ee08bcaa SHA512 d5a43283eba61576546dbce7791825607a813658a4ef68ed6d173f8438e08f6a84027a7ce75a748e245f8dd532ca6a9eb1afa0ce795517e77b08f03c29fea034
+DIST makefun-1.15.2.tar.gz 74602 BLAKE2B 1992eebfdbff6062ed60e1f66891995a91b7155792ef7b6e701d1d3ee5939ab40d3ab976674e25a5b97030cd7de59db2c69f3c215681cef2f80f2b64523f822b SHA512 b6cb588ebf491176b06e97201846b2a5cee65f60e34b5dbcc4878d8a55e7f9fcf4b58126cb3a4ca47f5d2726422dff9ee685566c5d093dbd8fd75119ecc796b2
diff --git a/dev-python/makefun/makefun-1.15.2.ebuild b/dev-python/makefun/makefun-1.15.2.ebuild
new file mode 100644
index 000000000000..b15e2249b8af
--- /dev/null
+++ b/dev-python/makefun/makefun-1.15.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Small library to dynamically create Python functions"
+HOMEPAGE="
+ https://pypi.org/project/makefun/
+ https://github.com/smarie/python-makefun/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/pytest-runner/d' -i setup.cfg || die
+ distutils-r1_src_prepare
+}