summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2025-02-21 17:28:09 -0500
committerConrad Kostecki <conikost@gentoo.org>2025-02-22 00:25:52 +0100
commit95ec451ab301fa613ca7adaa53c7e868c907f374 (patch)
treef7ce38933dea3ca87c9a7d97ff115f25db652f69
parentapp-misc/jaq: add 2.1.1 (diff)
downloadgentoo-95ec451ab301fa613ca7adaa53c7e868c907f374.tar.gz
gentoo-95ec451ab301fa613ca7adaa53c7e868c907f374.tar.bz2
gentoo-95ec451ab301fa613ca7adaa53c7e868c907f374.zip
app-arch/unrar: add 7.1.4
Signed-off-by: Joe Kappus <joe@wt.gd> Closes: https://github.com/gentoo/gentoo/pull/40692 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--app-arch/unrar/Manifest1
-rw-r--r--app-arch/unrar/unrar-7.1.4.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/app-arch/unrar/Manifest b/app-arch/unrar/Manifest
index ede81ebcaba3..eb9e4823b59e 100644
--- a/app-arch/unrar/Manifest
+++ b/app-arch/unrar/Manifest
@@ -1,3 +1,4 @@
DIST unrar-7.0.9.tar.gz 258287 BLAKE2B 4933d62c8b7ea227b5eee8ce078a08cbe7534f35641ee0ce33bdd246f1045c65f773894d5868738b2174ea2bb2858745b5bd31dc5f958ef70188bcb805165300 SHA512 4dff760bd69275dcd9bacac7a8fa9a6e68e2d047ea3775abc16a80d9a6e277b686153faafb1b711582d86eabfdf3254c601d9f585b28104dbd85ece4868876ed
DIST unrar-7.1.2.tar.gz 264081 BLAKE2B e5cd9c577ae4c8b8025970e597b7b270fe74beb47974ce038ce334c6cd49eb3bbbd1126eecf7093703f998f5a55a3be3ea911d950dd25040ef0f98272d5d84dd SHA512 3492334ef95916728af573f8f5bcb8d5a8c4a014b5daa0ffeaa67c9c56a5603a2389b030c6e0126064b1f281db5143907fa83f8c4249d23abc3273a5387d90d6
DIST unrar-7.1.3.tar.gz 266820 BLAKE2B c18f9ef0208c893a6c4ff1ac0df7abcd54216f2f6341a08083af695729cba6773ee1de74af8b0fc1fce94e90ce1cbbf14fbe34ad0c8f1a3dcd6a3598b978c706 SHA512 210a4c65e5c3f3a3f9561a8fab805b6a6a182ac6274f8671d22020076873952b92cb8cc2523943df20a97ed01415b38e2bb59082f03dd5f7da0d6e85dc9193d4
+DIST unrar-7.1.4.tar.gz 267194 BLAKE2B 926d45f61877878a8a7c998717526e8b10b70c6832b3761a6af6f4897f00c6edfd946b51b9a8e471affbb7e79dc166a952057f08aca9d128a18397446b8b767c SHA512 f1a9485f9d9bb7bb87779cfd442114c22c316423771d644251688e631232b516ee800bbf9bfecde53c429cb1a121b3de57e230f3fc08c27784d60d5587516d38
diff --git a/app-arch/unrar/unrar-7.1.4.ebuild b/app-arch/unrar/unrar-7.1.4.ebuild
new file mode 100644
index 000000000000..355f68e21b19
--- /dev/null
+++ b/app-arch/unrar/unrar-7.1.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib toolchain-funcs
+
+MY_PN="${PN}src"
+
+DESCRIPTION="Uncompress rar files"
+HOMEPAGE="https://www.rarlab.com/rar_add.htm"
+SRC_URI="https://www.rarlab.com/rar/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/unrar"
+
+LICENSE="unRAR"
+SLOT="0/7" # subslot = soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+PATCHES=( "${FILESDIR}/${PN}-6.2.6-honor-flags.patch" )
+
+src_prepare() {
+ default
+
+ local sed_args=( -e "/libunrar/s:.so:$(get_libname ${PV%.*.*}):" )
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed_args+=( -e "s:-shared:-dynamiclib -install_name ${EPREFIX}/usr/$(get_libdir)/libunrar$(get_libname ${PV%.*.*}):" )
+ else
+ sed_args+=( -e "s:-shared:& -Wl,-soname -Wl,libunrar$(get_libname ${PV%.*.*}):" )
+ fi
+ sed -i "${sed_args[@]}" makefile || die
+}
+
+src_configure() {
+ mkdir -p build-{lib,bin} || die
+ printf 'VPATH = ..\ninclude ../makefile' > build-lib/Makefile || die
+ cp build-{lib,bin}/Makefile || die
+}
+
+src_compile() {
+ unrar_make() {
+ emake AR="$(tc-getAR)" CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" STRIP=true "$@"
+ }
+
+ unrar_make CXXFLAGS+=" -fPIC" -C build-lib lib
+ ln -s libunrar$(get_libname ${PV%.*.*}) build-lib/libunrar$(get_libname) || die
+ ln -s libunrar$(get_libname ${PV%.*.*}) build-lib/libunrar$(get_libname ${PV}) || die
+
+ unrar_make -C build-bin
+}
+
+src_install() {
+ dobin build-bin/unrar
+ dodoc readme.txt
+
+ dolib.so build-lib/libunrar*
+
+ # unrar doesn't officially install headers, but unofficially, software
+ # depends on it anyway. There is no standard for where to install them,
+ # but the most common location (shared by nearly all vendors) is "unrar".
+ # FreeBSD alone uses "libunrar". Gentoo formerly used "libunrar6" and
+ # had a compat symlink for FreeBSD, then passed the compat location in
+ # ./configure scripts e.g. for sys-fs/rar2fs. Software in the wild
+ # seems to expect either "unrar" or "libunrar".
+ # See: https://bugs.gentoo.org/916036
+ #
+ # We now use the "standard" (hah) location, and keep the compat symlink but
+ # change the destination. The version-suffixed location lacks utility, but
+ # we would keep it if we could, just in case -- unfortunately portage is
+ # buggy: https://bugs.gentoo.org/834600
+ #
+ # Hopefully, no one has ever actually used it and therefore this does not
+ # matter. The odds are on our side, since it periodically changed location
+ # arbitrarily.
+ insinto /usr/include/unrar
+ doins *.hpp
+ dosym unrar /usr/include/libunrar
+
+ find "${ED}" -type f -name "*.a" -delete || die
+}