summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-08-20 17:33:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-21 22:54:09 +0200
commitab8d456f586322ca6af1f148c91c565f703167e4 (patch)
tree3bdef7b9ced8ee2fa678fa424de4fc90550eafa1
parentdev-python/types-setuptools: Bump to 72.2.0.20240821 (diff)
downloadgentoo-ab8d456f586322ca6af1f148c91c565f703167e4.tar.gz
gentoo-ab8d456f586322ca6af1f148c91c565f703167e4.tar.bz2
gentoo-ab8d456f586322ca6af1f148c91c565f703167e4.zip
kde-apps/libkcompactdisc: Block SLOT 5 unconditionally
The only revdep is blocking the other slot as well. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--eclass/gear.kde.org.eclass1
-rw-r--r--kde-apps/libkcompactdisc/libkcompactdisc-24.05.2-r1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/eclass/gear.kde.org.eclass b/eclass/gear.kde.org.eclass
index 3f8126dd1c01..eb05b406a7ae 100644
--- a/eclass/gear.kde.org.eclass
+++ b/eclass/gear.kde.org.eclass
@@ -256,6 +256,7 @@ if $(ver_test -gt 24.04.75); then
itinerary | \
kio-perldoc | \
kolourpaint | \
+ libkcompactdisc | \
signon-kwallet-extension)
RDEPEND+=" !${CATEGORY}/${PN}:5" ;;
*) ;;
diff --git a/kde-apps/libkcompactdisc/libkcompactdisc-24.05.2-r1.ebuild b/kde-apps/libkcompactdisc/libkcompactdisc-24.05.2-r1.ebuild
new file mode 100644
index 000000000000..497d11693753
--- /dev/null
+++ b/kde-apps/libkcompactdisc/libkcompactdisc-24.05.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=6.3.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Library for playing & ripping CDs"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="alsa"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus]
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/solid-${KFMIN}:6
+ >=media-libs/phonon-4.12.0[qt6]
+ alsa? ( media-libs/alsa-lib )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package alsa ALSA)
+ )
+ ecm_src_configure
+}