summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-05 20:12:29 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-05 20:22:47 +0200
commitabe46d1d2b36c182cb50db0eacfcb18f69214058 (patch)
tree924ea94ab75bf3817f03697fd3a9a79a2168e7ef
parentx11-libs/libcryptui: allow gnupg 2.3 (diff)
downloadgentoo-abe46d1d2b36c182cb50db0eacfcb18f69214058.tar.gz
gentoo-abe46d1d2b36c182cb50db0eacfcb18f69214058.tar.bz2
gentoo-abe46d1d2b36c182cb50db0eacfcb18f69214058.zip
dev-python/sphinxcontrib-asyncio: Bump to 0.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-asyncio/Manifest1
-rw-r--r--dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.3.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-asyncio/Manifest b/dev-python/sphinxcontrib-asyncio/Manifest
index cb1e2c53a042..d68bdd275752 100644
--- a/dev-python/sphinxcontrib-asyncio/Manifest
+++ b/dev-python/sphinxcontrib-asyncio/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-asyncio-0.2.0.tar.gz 10689 BLAKE2B 9e03989a1ed22d7d467bdb7626e2e908407a0de15a943a432ff9707340f0cefe7caf1684380c25764637798b585b32287c4bcfc0f2014a78b7019547405e7ded SHA512 2ca25717c03385ae9bf879b8efeab8d508292d07f96d941032720d755d3db2e7bbc3c9a33c6103af9d83849ed8878bea1048d349bd0873288ee2addfee9756b7
+DIST sphinxcontrib-asyncio-0.3.0.tar.gz 11622 BLAKE2B 8c3358ad191e12e79767be6e6f3800e5de423d9a5ad005bdb416aa7a601cddc5f115db3e9b27213c06dbc341b671cbacd00217b65496baada40bfe257069abfa SHA512 fa66a2a9b5f89327686481f46d8e5be0b674f6355c8c0eeb862bf0ca0b5bb848121c5ed153780f653242faf1b82debc6917c3f6046244cce0f1423303a324f29
diff --git a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.3.0.ebuild b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.3.0.ebuild
new file mode 100644
index 000000000000..b4063a15cf88
--- /dev/null
+++ b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="sphinx extension to support coroutines in markup"
+HOMEPAGE="
+ https://github.com/aio-libs/sphinxcontrib-asyncio/
+ https://pypi.org/project/sphinxcontrib-asyncio/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs
+
+src_prepare() {
+ # fix for sphinx >= 4.0
+ sed -e 's/PyModulelevel/PyFunction/g' \
+ -e 's/PyClassmember/PyClassMethod/g' \
+ -i sphinxcontrib/asyncio.py || die
+ default
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ rm "${BUILD_DIR}/install$(python_get_sitedir)"/sphinxcontrib/__init__.py || die
+}