summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-07 02:33:45 +0100
committerMichał Górny <mgorny@gentoo.org>2021-05-07 13:57:52 +0200
commitbfc7c281983d65abfefcf5a289bc6a5f841253b2 (patch)
treec6743891d8630fc750c7860aa45f28b322dac7c8
parentdev-python/loky: Update metadata (diff)
downloadgentoo-bfc7c281983d65abfefcf5a289bc6a5f841253b2.tar.gz
gentoo-bfc7c281983d65abfefcf5a289bc6a5f841253b2.tar.bz2
gentoo-bfc7c281983d65abfefcf5a289bc6a5f841253b2.zip
dev-python/versioneer: Port to python3.10
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/versioneer/versioneer-0.19.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/versioneer/versioneer-0.19.ebuild b/dev-python/versioneer/versioneer-0.19.ebuild
index 611e8297f91d..7575c2e1e409 100644
--- a/dev-python/versioneer/versioneer-0.19.ebuild
+++ b/dev-python/versioneer/versioneer-0.19.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -33,5 +32,5 @@ python_test() {
git config --global user.email "you@example.com" || die
git config --global user.name "Your Name" || die
- ${PYTHON} test/git/test_git.py -v || die
+ "${EPYTHON}" test/git/test_git.py -v || die
}