summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-14 04:38:21 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-14 05:39:12 +0100
commitc6c42bea1d1720a25ded959608d698405922c063 (patch)
treefeff6f483d77a72b8cf32a06aa3b076e315f6edf
parentdev-python/boto3: Bump to 1.35.60 (diff)
downloadgentoo-c6c42bea1d1720a25ded959608d698405922c063.tar.gz
gentoo-c6c42bea1d1720a25ded959608d698405922c063.tar.bz2
gentoo-c6c42bea1d1720a25ded959608d698405922c063.zip
app-admin/awscli: Bump to 1.36.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.36.1.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index f1df601ab5b4..cc94f5755faa 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.35.20.gh.tar.gz 2817368 BLAKE2B 92c86af16eb29a22c437491c938c08d4a
DIST aws-cli-1.35.23.gh.tar.gz 2819656 BLAKE2B 6e9d20410344f075ce12bfc8c0a49941a846f02304de9a30516376d0b6666b8c0a9affb36dd94a463f48f17f478f5d27e0f7375a48c63eca1b3a28927211e6aa SHA512 9075af833da9abc9494a2dd01a987b874e2b4444d7d5d1f4f974da1b56940b88603e8ec115662c85c2beb7cb70a65c3bcdbbd5510a1973433f8030efc6a1c69a
DIST aws-cli-1.35.24.gh.tar.gz 2820137 BLAKE2B 04783d2232433070fdd468070e9a924a8737212cd5013f5c296d8cb2f287c3dd0dc9ecd5b73656b807c45db02bf28a10dd2049f2a06ed29f93e73de4413fbf7f SHA512 36d4f9f692c3bf199bbfb5464a089be9904e58a597fc352e40c5438c5b45c7e74e8123952fd502b7d9869c4629f95f46d5b1a59b0d436a22668182efd8eccd22
DIST aws-cli-1.36.0.gh.tar.gz 2821055 BLAKE2B cb6fa31e3f8377e52fe35a0eef47f49f48e35d1eacea9cd63182f12a2b8d2249329cc880c56e899b69fdb9dfc44446e236362e8d7564d31ff6f236cb21ae38d2 SHA512 c6cabe0fd752e87174a9e65a9185144dc128eee0e6d5f5915ea85e0b8aa5d62fb40fefdb8f8014f1a3ae93aaad23384e7e828a06f448df536924d97c7fbb92b1
+DIST aws-cli-1.36.1.gh.tar.gz 2823200 BLAKE2B 9a534ce116f8c94c4fc923e298957b6185e74c5bcff3c4c67069a70a09e4218596636bf4f482326503c4f58a192113e238a75840f6c316624a31caa69aa35a05 SHA512 7fc2ea786bda3a5f861a8f9afa0126bc4c89bf9ae6201e7a7878807aea85134c77785b36e158da91169a943195d8819780401f67fcbf1dd99546875525705675
diff --git a/app-admin/awscli/awscli-1.36.1.ebuild b/app-admin/awscli/awscli-1.36.1.ebuild
new file mode 100644
index 000000000000..2960403cf7e0
--- /dev/null
+++ b/app-admin/awscli/awscli-1.36.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y-1).(z+59)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) - 1)).$(( $(ver_cut 3-) + 59 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=(
+ "${serial_tests[@]}"
+
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}